Zebra printer will not print CORRECTLY through Oracle application(s)

Billing and customer care
Billing Support Systems
Desktop management applications
Distribution/logistics applications
i2 Technologies
Manufacturing applications
Microsoft BizTalk Server
Microsoft Windows
Online transaction processing
Oracle Application Server
Oracle Manufacturing
SAS Institute
SQL Server
Supply Chain Management
Glad to see that some of you all have experience with Zebra printers!!! My problem is that I cannot get my custom Oracle application to print correctly to a Zebra TLP 2742 printer. The problem started when an (older) hand held "pistol" scanner failed. Connected to a laboratory balance via Omnilink box and two "Y" PS2 cables (called "wedge" cables), the scanner, Omnilink and cables were all replaced and now function properly. In the course of troubleshooting the issue, the core chipset and BIOS of the IBM ThinkCentre 8183-TUH (SFF) were updated. After the driver and BIOS update, the printer will print via Zebra software (Bar One Lite) but from Oracle apps, I get a "garbage" overlay on top of what appears to be valid bar code information. The printer is connected to COM2 and WAS NOT connected to the system at the time of the flash process. There is NO Windows printer driver installed, as neither the Oracle applications nor Bar One utize the OS to queue print jobs. I have done the following: - replaced the printer - replaced the PC with a new 9210-KUA system - re-installed the Windows 2000 SP4 OS, Office 2000 SP3 and McAfee 8.0i from bare metal (hand built) on the 9210-TUH system - replaced all cables - installed the existing Oracle applications - replaced newly installed Oracle applications with fresh recompiled apps using the latest JVM. The same result is acheived from either the original system (flashed BIOS/core chipset update) or the new system. I am the Instrument System/PC support analyst; the Oracle Developer performed the re-compile and installation of the apps; the Application Support Analyst has been involved in the process and cannot see any defects in the installation or configuration of the system or the Oracle apps. Per a suggestion from another analyst here, I will be installing Services for Unix on this system later today. Any and all comments and/or suggestions (and Yes, I do need to keep using the TPL 2742 printers....) will be considered.

Answer Wiki

Thanks. We'll let you know when a new response is added.

is there a printer font that is missing from the oracle program?

Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Poppaman2
    ALL - The addition of "Print Services for Unix" resolved the issue. Thanks for the reply/replies received... FYI - the fonts are resident on the application server in our situation, and the apps do not print through the Windows print spooler, and other workstations in three locations work/worked fine during the time this workstation was down. Good call though....
    0 pointsBadges:
  • AaronCutshall
    I am used to working directly with the ZPL language that the Zebra printers use. Therefore, one thing that I would do is to capture the output to a file instead of a COM port. Then look at the resulting ZPL code to see if the problem is in there. If you send the file to the COM port (like this: COPY TEST.ZPL COM2: ) it should duplicate the problem. At least you might be able to narrow the problem a bit more. Perhaps it's with your barcode program??
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: