Windows XP System Hardening – Sysprep problem

Microsoft Windows
Patch management
SQL Server
I'm currently going through a list of required security changes on one of our system that we use to create a master image to sysprep and clone to multiple target systems. I've made a large number of detailed changes to the system and now it appears that sysprep is unable to complete the mini setup process after restoring the image to a new system. When the system boots it detects the drivers (as we instructed it to do via UIU - Universal Image Utility from BigBang software) and then it displays the Set Computer name dialog from the mini setup wizard. On our systems that should be the only dialog since we customized the sysprep.inf to set defaults for all other setup questions. It accepts the computer name setting and then continues until it reboots automatically and then it begins the driver-detection process all over again as if it was unable to save the state from the last time. This cycle repeats ad infinitum, can't seem to get past it. I've already verified the basic permissions to run sysprep are enabled, Administrators has rights to backup files and directories, Load and unload device drivers, Modify firmware environment values, and shutdown the system. I'm wondering if anybody knows sysprep's inner working well enough to help me guess what I might have locked down that breaks the mini setup? Does it run as Administrator during mini-setup or is it LocalSystem or some less privileged account?

Answer Wiki

Thanks. We'll let you know when a new response is added.

I don’t have the answer, but can recommend some utilities which may point you in the right direction.

Download filemon and regmon from Microsoft Technet (formerly, and see if you can get them to run at your initialization time – prior to the driver detection (I’ve not done this – but it’s worth a shot) time. This (should) give you a record of what registry calls are being made – and the results of them – to allow you to get closer to the problem.


After doing some serious googling, i have found most people are saying the cause of this error is including windows media player 11 in the image However, i have an image without WMP11 that is still having problems so i need to keep digging. Hope this helps


Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Lirria
    I know sysprep is at times kinda picky about things- I would recommend breaking down the install to see if you can identify where it's dieing. I would start by removing the sysprep.inf and see if it works with out it (yes it does mean answering all the prompts, but it might help isolate where it's failing. I assume you have tried this on a different computer - sometimes the computers just don't work well with sysprep (I have a Dell Latitude d410 that will not work with sysprep - it blue screens and reboots - can't figure it out so I just install each one from scratch) Lirria
    0 pointsBadges:
  • adanbluearc
    I am not sure if it's the same problem you're having but very recently I had a problem when we were updating our image. After struggling with this for a while, we found it to be Media Player 11. I wouldn't be surprised if a lot of people are having similar problem, because reverting to an earlier version fixed it. Here are the notes I wrote for our team. Hope this helps. ----------------- "The system is not fully installed" error message You get this when booting up a system after doing Sysprep. This is caused by Media Player 11. As of this writing, you must remove Media Player 11 in order to have a working image. Go to Article ID 320279 in Microsoft Knowledgebase. You can follow the instructions there to fix the system, although I manage to do it by removing the hard drive from the target system and plugging it into another system using USB cable. Note that it doesn't mention Media Player is the culprit, I found this in another article in Google.
    0 pointsBadges:
  • Lirria
    Yes - that's the problem I had too - removed media player 11 from the system before syspreping and everything worked great after that. Lirria
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: