Windows 7 must restart print spooler every morning in order to print

215 pts.
Group Policy
Server 2003
Windows 7 deployment
We are currently deploying Windows 7 64bit PCs within our organization. Some of the computers need to have their print spoolers restarted in the mornings or else they won't print. 

After the spooler has been restarted they seem to print fine. We deploy printers via Group Policy from Windows 2003 and I administer the print management with Windows 7 so that I can install the Windows 7 64-bit drivers.

We have a variety of printers including Ricoh and HP. None of the printers will work on my PC first thing in the morning. Upon checking the properties of the printers, there is nothing listed in the ports tab when this happens.  When I stop and restart the print spooler suddenly everything appears in the ports tab and I am able to print just fine. I am using mostly the universal PCL 64-bit drivers for the Ricohs and the HPs alike. 

I know there has got to be some sort of error that is happening and hanging the print spooler upon start-up, but I'm not sure what it is. I tried setting the print spooler to restart service automatically on subsequent failures, but then that just hung everything up and I had to restart the spooler on the server and then on the PC before I could print again. 

There is nothing in the event logs to tell what's going on. I also have PDF Creator installed if that makes any difference, although it is not installed on any of the other computers and I still had the print problem at least once on one of them.

Restarting the print spooler on the server makes little difference except that I have noticed if I try to connect to the server print management console too many times in a row nothing will show up in the print management console at all unless I restart the 2003 server print spooler as well as my Windows 7 print spooler. 

I think that has to do with the fact that Windows client computers are only allowed so many connections to 2003 before it won't allow anymore which is done by design by Microsoft and dumb in my opinion. If the printers are directly connected to the users via Standard TCP/IP then there is never a problem. 

The problem only occurs when the printers are connected via the group policy deployment of the server. Any ideas? We only have a few Windows 7 PCs right now, but if this is going to continue to be a problem we'll have to cut out deploying printers with group policy.  Someone once mentioned disabling bidirectional printer support because a resource might be in use that requires admin or system privileges in order to print, however, this was only a solution to a problem where documents wouldn't print until the print spooler on the server was restarted and then they would print. Thanks for any advice! Erin0201 :)

Software/Hardware used:
Windows 7 64bit OS on Client, Windows 2003 R2 on Server, HP and Ricoh network printers

Answer Wiki

Thanks. We'll let you know when a new response is added.

Do you have any 32 bit Windows 7 machines and do they show the symptoms?

I’m wondering if it is because to are using Win 2003 GPO against Win 7.

Has this problem shown up in any non Win 7 machines

First off, this is not really an answer above….WIN 2003 is built to support all GPO’s for WIN 7. I have this exact same problem across the board. Multiple models of printers. I use the PCL drivers for my networked printers and host 3 different brands/models. All printers have the same issue. Sometimes this issue will go away for weeks at a time. Then it comes back for 7 or 8 days straight….then it goes away. I still have not found a concrete answer as to why this happens. I have uninstalled / reinstalled printers multiple times and this just seem to be a very random, common problem when upgrading to Win 7. Only machines that i HAVE NOT seen this on are clean factory Win 7 machines that we order from Dell. But when i UPGRADE, i am faced with this problem.

Discuss This Question: 14  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • petkoa
    It sounds like this type of printer deployment via group policy isn't happy with the printers power-saving mode? Sure, your printers will go sleeping at night - I assume you don't power them off, right? BR, Petko
    3,140 pointsBadges:
  • Denwood
    We are having a similar issue on a Win7 (32-bit) machine. The copier/printer is installed going through the "add a printer" wizard. The printer is being shared off of a print server. Periodically, the print spooler stops and requires a reboot of the machine. I cannot even restart the service (logged in as an administrator). I have deducted that it cannot be a powersave issue as it happens sometimes within a minute of a previous (successful) print job. I will keep following this post to see if any suggestions work for my similar issue.
    390 pointsBadges:
  • Lens
    I have exactly the same problem in a very simple two computer network. W7 is printing to a printer on a Vista machine. After W7 goes to sleep then anything printed just stays in the printer queue on W7 and never gets sent to the Vista printer. It just sits there until I reset the spooler or reboot W7. THis is a royal pain -- I was hoping W7 would be better than Vista -- I never had this prblem on XP or Vista.
    10 pointsBadges:
  • Mirumi
    Just dumped Vista Business and loaded Win7 64 bit. All the same problems as discussed. Any answers on this yet?
    10 pointsBadges:
  • Mnipmpn
    I had this exact problem and found the soultion! I too have a w2k3r2 environment with a mix of XP & Win7 (Vista Blows!). The issue with printing was initally remedied with a simple batch file ("Net Stop Spooler && Net Start Spooler") which applied with a delayed start to the system via scheduled tasks. I realized that any driver updates required me to touch each Win7 box to complete. --Needless to say this was quite a pain!. Started looking at Print Deployment via GP, worked straight out of the box for XP, no issues, logging worked too! Still no Win7 deployment! arrrggghhH!!!! im ready to chuck everything out the window by now! Found the following articles: The issue is resolved by updating the schema and prep domain to S2k8r2 by following this article: I was also running e2k7sp1 at this time and learned sp3 had already come out. Upgraded exchange to sp3 first. (took about 1.5 hrs for 40Gb DB and 140 boxes) Backed up AD w/ schema. Downloaded and ran s2k8r2 ADPrep32.exe from the Schema FSMO master. the commands are available in the shell Adprep32 /ForestPrep, ADPrep32 /DomainPrep, ADPrep /DomainPrep /GPPrep.. Note the domain and forest still operate at 2k3 Native level, extended atrributes are included and functional at this point. Once completed. you will want to only manage Printer Deployment from either a Win7 W2k8 server (r2). Assuming your network has a centralized print server. you can install the Print Management feature on the w2k8 box and connect directly to your print server. I created a single GPo named "Printer Deployment" applied it to the entire domain, and set each printer with security for the specific group that needs access to it. In this GPo, you will need to add PushPrinterConnections.exe to the side in which you choose to deploy the printers. PPC.exe is available on the s2k3 box. Follow the "" article for this information. Added the printers, applied the GPo to a few test machines first. Walah! it works like a champ. The option for "-log" in the script only seems to work for XP and 2k3 not 7 or 2k8. I apologize if this is a bit confusing, but following those articles will get you where you need to be. I dont normally reply to threads, but this was quite the adventure to figure out! Good Luck! If you get stuck, start over! i had to a few times!. Also, do not add the printers directly from the GPo, use the Print Management window to deploy, otherwise, the log file states that no printer connections are found in AD. The process fails. You may have to remove a single printer from the directory and re-list it, if you have this issue. Reply if need be and i will try to get back to you!
    10 pointsBadges:
  • Daboss01
    any solution? thanks
    10 pointsBadges:
  • Featured Member: Petkoa - ITKE Community Blog
    [...] Windows 7 must restart print spooler every morning in order to print [...]
    0 pointsBadges:
    Hi, we're having the same problem where I am. The differences however are that we are rolling out 32 bit windows 7 machines and printers are not installed via GPO. They are installed manually. At the moment we only have a handful of customers on Win 7. One of the customers (after logging off the previous evening) comes in the following morning and is unable to print. If I restart the print spooler then she can print - until the next time she logs off and then the cycle is repeated whereby I have to restart the print spooler again. I have checked the print spooler settings in services and it is set to automatic restart. Any advice?
    10 pointsBadges:
    Bump!! Windows 7 Enterprise x64 Deployed via WDS (Clean Install) Printers deployed via GPO (Printer Management) Documents go into the Print Queue, and then like 10 minutes later are gone. Nothing ever happens at the print server, or the printer itself. Restart the Print Spooler service on said computer; all is fine usually for at least 24 hours. Restarting the computer does NOT solve the issue. We have to restart the Print Spooler Server after the user is logged in; and we have to "Run As Administrator" to do it, as all our users are just "Users" on the Windows 7 Systems.
    25 pointsBadges:
  • Ranjeetkmr
    i also have the same problem . any answer?
    210 pointsBadges:
  • Nichomach
    PDFCreator has been a factor whenever we've seen this sort of behavious; removing and substituting CutePDF where necessary has resolve the issue in most cases.
    10 pointsBadges:
  • yangerr
    If I reformat the computer then the problem will settle?
    10 pointsBadges:
  • bhannah
    Since all of my printers are running from IP based addresses, I am not having this kind of issue and I do not use DHCP so my systems do not lose track of the printers because of static address. I suspect though somewhere your machines are getting a command to turn off the printer spooler on the local machine. That needs to be changed in the startup of the registry, that it this is enabled at all times.
    4,590 pointsBadges:
  • qasimarshad

    The biggest part of the problem I was facing was mismatched drivers; especially when dealing with a combination of 32-bit and 64-bit architectures. All of my workstations are 32-bit, but our servers are all 64-bit. It does make a difference. The other part of the problem involved third-party/vendor drivers, instead of standard Windows INF packaged drivers. If you can get WHQL / WDF drivers, I HIGHLY recommend doing so.

    These are the steps I took, in a nutshell:

    Remove all drivers and queues from the workstations and from the server (if possible). Clean out the print spooler folders on the workstation (Google this for detailed steps). Do this from the consoles, not from Remote Desktop sessions.

    Remove all Group Policies that reference printers (the entire Group Policy, not just the individual entries). For me, this was a lot of work - I had to recreate all of the other settings in a new Group Policy Object. This step is more important than I expected.

    On the server itself, use the Print Server Management snap-in to install the latest WHQL/WDF/inf 64-bit version of the necessary drivers. Avoid "universal" and vendor proprietary drivers where possible, using only Windows INF packaged drivers.

    On a 32-bit workstation (important!), use the Print Server Management snap-in to install the latest 32-bit version of the necessary drivers. The version numbers should be the same as the 64-bit versions.

    On the server itself, use the Print Server Management snap-in to create the appropriate print queues and shares.

    Use Group Policies to allow print drivers to install on the workstations. (

    Finally, connect to the print queues on a couple of workstations and test.

    If all is good, use Group Policy Preferences to map print queues (if desired). Ensure this is a new, separate Group Policy Object with only User defined objects and is applied only to User containers within Active Directory

    95 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: