Why am I getting null values for Extended ASCII Codes in following code?

Tags:
ASCII
Oracle
SET head off
SET pagesize 0
SET linesize 120
SET trimspool on
SET feedback off
SET verify off
 
SET serveroutput on size 5000
BEGIN
   FOR i IN 32..255 loop
      Dbms_output.put_line(i || chr(39) || chr(i) || chr(39));
   END loop;
END;
/


Software/Hardware used:
In oracle 11g database.
0

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • carlosdl
    That is probably related to the database's character set.  They show correctly for me, but I don't have a test database where I can change the charset to confirm my hypothesis.
    84,805 pointsBadges:
    report
  • ToddN2000
    I agree with carlosdl, most likely a char set problem. What character set are you using?
    133,645 pointsBadges:
    report
  • GeorgeMuller
    AL32UTF8  NLS_CHARACTERSET

    I am new to company ... but we did change from a previous ASCII character set to the Unicode character set from.  

    I think it may have happened then.
    15 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: