VSS Backup Fails On Servers Running SQL Server 2005

SQL Server 2005
VSS Backup
I have 2 servers running SQL Server 2005. One has Standard and the other has Express. Both are running on Server 2003 w/SP1. Since I installed SQL 2005, Backup Exec (through Remote Agent) has been unable to backup VSS on either computer most of the time, although it's occasionally worked for a day or two but usually not on both servers at the same time. When I check the event log there are COM errors starting VSS (which I have set to start automatically) and VSS is not only stopped, but actually disabled. I installed the hotfix from MS KB891957 and also ran these commands to re-register several DLLs and rebooted: Cd C:Windowssystem32 Net stop vss Net stop swprv regsvr32 ole32.dll regsvr32 vss_ps.dll Vssvc /Register regsvr32 /i swprv.dll regsvr32 /i eventcls.dll regsvr32 es.dll regsvr32 stdprov.dll regsvr32 vssui.dll regsvr32 msxml.dll regsvr32 msxml3.dll regsvr32 msxml4.dll Net start swprv Net start vss After those steps I found a reference to a problem that seems to be created when SQL 2005 installs the SQL Server VSS Writer. Apparently it screws up the COM+ catalog, which I was able to verify from the command line by using the vssadmin list writers command (nothing was listed). In order to fix that I deleted the HKLMSoftwareMicrosoftCOM3 registry key, booted to the Recovery Console, and renamed C:WindowsSystem32clbcatq.dll to ~clbcatq.dll. Then I started Windows and went into Add/Remove Windows Components and clicked Next so COM+ would be reinstalled and the catalog rebuilt. The VSS writers came back, but when the databases were backed up (using T-SQL's BACKUP) the SQL Server VSS writer stayed in state 5 - Waiting For Completion, and as a result when Backup Exec tried to do it's VSS backup later it caused VSS to fail several times and eventually it got disabled again. Finally, I found the registry key that tells SQL Server whether to use the new VSS Writer or the MSDEWriter for backups (HKLMSYSTEMCurrentControlSetServicesVSSSettings) and set MSDEVersionChecking to 0, which is supposed to make SQL Server default to MSDEWriter. I also disabled the SQL Server VSS Writer service. This morning when I checked the backup VSS was disabled again and so was the MS Shadow Copy Provider service. When I enabled them and listed the writers again SQL Server VSS writer was in state 5 and of course the VSS backup failed. After re-enabling VSS and MS Software Shadow Copy Provider, as well as disabling the VSS writer again I ran the database backups followed by the Backup Exec job that backs up VSS. The database backups used the SQL VSS Writer again but this time they completed (VSS Writer state was 1 in vssadmin) and the Backup Exec job completed as well.

Answer Wiki

Thanks. We'll let you know when a new response is added.

The backup last night failed again, but this time the SQL Server VSS Writer stayed disabled on one server. The other server had it enabled again and vssadmin list writers showed it at a state of 1 (no problems). However, VSS was disabled on both servers and Backup Exec wasn’t able to back it up on either.

Up until now I’ve had the T-SQL scripts started by a scheduled task on the Backup Exec server. This morning I moved the tasks and scripts to the servers with the databases. I also tested it again (ran db backups followed by the Backup Exec job that fails) and all jobs ran fine. VSS kept running on both servers as well.

Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Vurbal
    I finally have the t-sql backups using the MSDE Writer, but I still haven't been able to backup VSS afterwards. Unlike the SQL Server VSS Writer though, the MSDE Writer doesn't seem to know that something's wrong after the db backup runs because it's in state 1 when I check it in the morning. Based on Event Log entries I did figure out that whatever is going on is happening at the end of the first backup statement in the t-sql script. Even though the log and database backup commands that follow it are executed (which I verified by checking the contents of the backup file) the event log shows an entry for each additional backup command saying that the device is in use. After that, the Backup Exec job isn't able to access VSS, so I'm sure it's already disabled. The really strange thing is that I can't reproduce it manually. My nightly backup process goes like this: 9PM - Database backups run 10PM - Backup Exec backs up everything except VSS and files I know will be in use 11PM - Second Backup Exec job is queued to backup backup files from t-sql backups and VSS When I run the database backups manually the VSS Writer doesn't get stuck and I don't get the device in use Event Log entries. Not surprisingly, after that the VSS backup job in Backup Exec goes fine. For now I've re-enabled the SQL Server VSS Writer and set it to manual so I can start it right before the database backup and stop it right afterwards. I don't know if this will help because I'm not sure exactly when VSS is being disabled, but if it doesn't work I'm either going to have to come in on the weekend or stay late one night so I can run the whole backup process just to find where it fails.
    0 pointsBadges:
  • MozyServerError6 and VSS Writers - LGR Internet Solutions - Web and Blog Consulting
    [...] many Google searches I finally came across this page “VSS Backup Fails On Servers Running SQL Server 2005“. There were a few differences like the fact that this computer was running Windows XP [...]
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: