VMware and NT4

95 pts.
Virtual Machines
Windows NT
I cannot get a NIC to work on NT4 VM. I imported from a legacy machine that needs NT4 to run software installed. I was able to import it to a VirtualMachine, but the Realtek 8139 NIC is not found so network connectivety is not working. I cannot find ANY VMware hardware in the add/remove section. How can I get this machine on the network? Iam using VMserver and VMconverter (free vers). Thanks, Troy

Answer Wiki

Thanks. We'll let you know when a new response is added.

I dug and dug and dug…. but found nothing…. so I went back to my old school ways! I verified the network setup for another VMware virtual machine. I then compared it to my NT4_vm. I believe it should have installed an AMDpcNET NIC. The network card was not detected…. but hey, NT4 wasn’t plug and play. I attempted to get VMserver to add another one, but I still got nothing. I tried to add the AMD NICs, but I was asked for drivers, which I thought should be on the server already. I tried the faithful paths from yesteryear, and got it ‘somewhat’ installed, but it still wouldn’t see the network. Finally, I resorted to downloading full drivers for AMDpcNet family NICs (NT4) and installed them by simply saying ‘install from disk’, and voila! I now have a NT4 box that should run for a very long time if required.



I had the same problem. Eventual solution was to startup the VM (VMserver) then select “Install VMware tools” (even if they are already installed) Select “OK” until the Installshield wizard starts, don’t OK that, just leave it.
CD drive should now be showing a virtual VMware disk.
On NT, go to Network neighbourhood / Properties / Adapters tab,select <add New]
Select [Have Disk] then specify path:
D:\Program files\VMware\VMware tools\Drivers\vmxnet\winnt
This should install VMware Virtual Ethernet Adaptor. When complete, you can cancel tools install.



Thank you for this tip AMDpcNet family NICs NT4 it worked for me, after I used VMware converter to convert physical nt4 to virtual machine

Discuss This Question: 1  Reply

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Jerry Lees
    This answer looks correct, sounds like you need to install the drivers for the NIC. The last part of this answer should get you well on your way.
    5,335 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: