User profile related query in AS/400

70 pts.
Tags:
AS/400
AS/400 user profiles
Hi, I need to add one particular user profile to fix work station ID. Is it possible? If yes, please guide me how can I? Example: My user profile is venky484. My work station map id is QPADEV1111. If I  try to log in  that particular work station need to work and other wise it won’t allow to login. Same as no one can't  log in with same work station ID in future QPADEV1111 .
1

Answer Wiki

Thanks. We'll let you know when a new response is added.

Do you have an AS400 system administrator?

Is that *DEVD in a vary off status?

Is there a job already logged into that work station?

Try WRKCFGSTS CFGTYPE(*DEV) CFGD(QPADEV1111) 

Discuss This Question: 5  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • venky484
    Hai , Thanks For the reply . my self an  AS400 admin. my client requirement is   to creat the user profile then add fix worksatation ID to user profile .we have different types of bussiness users on system. we need to mape the user profile with FIX work station ..is it possible ????
    70 pointsBadges:
    report
  • ToddN2000
    Sounds a little confusing. Is the device not letting anyone login? Then the device may be disabled. You can fix this by using the WRKCFGSTS command mentioned above. If it's one particular user they may have reached the max number of signons. You can look for a phantom session that may still be active using operations navigator and going to active jobs.
    132,760 pointsBadges:
    report
  • lance2221357
    Before Signon Display system  allocated Device ID, So only wait user Logon in initial program you can check Device ID match user ID.
    270 pointsBadges:
    report
  • Yorkshireman
    You need to authorise that userID to the workstation. 

    look at the device descriptions security settings and add an explicit authority - or if you sre using group profiles or autls  place the user in the appropriate grouping and check that that grouping is authorised. 


    6,085 pointsBadges:
    report
  • TheRealRaven
    And you probably also need to authorize the user to the device *MSGQ, probably named the same as the device.

    In the case of user VENKY484, are you a *ALLOBJ or *SERVICE user? If so, you might always need explicit authority granted to you in order to use a workstation device. See system value QLMTSECOFR.

    And why would you need a device with a name that begins with "QPADEV"? Those should only be auto-configured devices. They shouldn't be assigned for specific users. If you want users to use particular devices, then create one with a name that doesn't begin "QPADEV". You should be able to separate auto-configured devices by name.
    35,090 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: