USB Flash Drives Not Installing On XP

Access control
Application security
Backup and Recovery
Career Development
Current threats
Desktop management applications
human factors
Instant Messaging
Microsoft Exchange
Microsoft Office
Microsoft Windows
Patch management
Secure Coding
Software testing
SQL Server
Storage management
Tape drives
Web security
Hello All! I've been noticing recently that certain USB drives have not been installing automatically to windows XP pro. I'm working on one right now and have not found a solution to it yet. A user needs to install a Sandisk Cruzer Mini USB Drive to her machine which uses XP Pro. Instead of installing automatically, it goes to the Found New Hardware Wizard and will not find a driver and install from there. I tried uninstalling what it tried to install under device manager and replug in the USB drive but the same thing happens. I've looked over some plug and play stuff and even went in to regedit to try to uninstall what could be left behind in the local machine reg keys. That didn't work. I searched a driver site and Sandisk's site but could not find a driver except for one for '98 SE. And it won't let me install that one either because it determines that I have XP and says that XP shouldn't need to download a driver. Someone out there should have a solution to this. I'm not the only one. haha! But seriously, I need help because I know I'm going to run into this some more with other users seeking help with it. It's gotta be something with the system and not the USB drive. The USB works with other XP machines, just not this one. Please Help! Thank you!! -thecheyguy

Answer Wiki

Thanks. We'll let you know when a new response is added.

My pc is a few years old, so only has USB 1.1
I installed a card to take USB 2 devices.
It is very ‘flaky’, working sometimes and not others.
If I plug my USB drive into the 1.1 slot, that always works.
I am using XP Pro.

Does your machine in question have a similar setup ?


Discuss This Question: 9  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Squibc4
    Dear i think you can resolve that problem by updating your OS with service pack 2. after that go 4 patchs and
    0 pointsBadges:
  • Accountantit
    The problem I had with these USB's on XP Pro is that I had a network drive assigned the letter that the system was trying to use for that USB and I went into disk management and assigned it an unused drive letter and it worked fine.
    0 pointsBadges:
  • Dgonza365
    hi, I ran into this too- ran updates from Microsoft and all is well now... funny thing was the event viewer did not really specify an error that I could troubleshoot...
    0 pointsBadges:
  • Poppaman2
    Some thoughts: 1. I have encountered this or similar issues before, and have found that USUALLY, simply plugging the problematic device into a different USB port resolves the issue. 2. What shipset is your USB controller using? There may be alternate drivers available (NEC has USB 2.0 drivers for example...) 3. IF the USB ports are from an add in card (CardBus or PCI), try moving the USB controller to a different slot/bus.
    0 pointsBadges:
  • Dreamscape
    I have a time or two had to remove all usb settings from the device manager and then refreshed to reinstall the drives. Jump drives really do want to have the first available drive, right after devices installed on the machine. Mapped drives will stop the jump drive from assigning a drive letter. Also make sure you have an up to date bios on the machine as well as updates from the PC manufacturer.
    0 pointsBadges:
  • VCAISEngineer
    My experience with USB storage devices and some Windows XP systems was exactly as AccountantIT reported in his response. Before you go to all the trouble mentioned in some of the other responses try reassigning the drive letter. I give my users the following steps: Start | Control Panel | Administrative Tools | Storage | Disk Management then Right-Click on the device that is having the problem and select Change Drive Letter and Path and give it an unused drive letter. It appears that XP has a problem dealing with some network resources that are mapped as drives. It tries to assign the USB devices the same drive letter and that won't work.
    0 pointsBadges:
  • King300
    Check: 1. Are the USB ports on the XP machine USB 1.0 2. Is the drive USB 2.0 3. If both above are true, is the drive downward compatable? Some are. If the above is the situation, the solution might be to add a USB 2.0 port to the machine.
    0 pointsBadges:
  • Ladrick
    My Suggestions: 1.Install XP SP2 and get the latest updates/patches 2.Check to make sure that the XP hasn't assigned the USB Drive with a drive letter that has already been taken by a network drive or secondary HDD. Logical Drive Manager - check there Also could there be any services such as drivestopper stopping the device from being installed?
    0 pointsBadges:
  • Vinayakpatil
    i know this problem please update sp2 & install all patches from microsoft site hope u r problem will solved
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: