Urgent Help: web-Forms 6i don’t work after Upgrading the db from 8i to 10g

Backup and Recovery
Data/Application Integration
IT architecture
Microsoft Windows
Oracle 10g
Oracle 8i
Oracle administration
Oracle Business Applications
Oracle Database
Oracle development
Hi, We have web-Forms 6i that are deployed on a server A and run against a database installed on a server B. The database was recently upgrated from version to 10g AND moved from the server C to the server B. However we're using now for the server B the alias we've used for the server C. When launching the web-Forms we get this error: 1034-ORACLE not available ORA-27101:shared memory realm does not exist SVR4 Error: 2: No such file or directory. After providing the connection parameters the same error comes up. The sqlplus is running fine on the Forms 6i machine against this 10g db. The db is up and running and we have Forms 4.5 that are running against the 10g db almost fine for 2 days already. the tnsnames.ora file is using the alias for the db, all the SIDs are lower case, so we tried to "cover" properly the environment settings. Please, help. We don't have an Oracle DBA and the db was upgraded by consultants that didn't reply to our questions yet. Couldn't find any hardcoded info that is pointing to the host C. Please, advice. Thank you.

Answer Wiki

Thanks. We'll let you know when a new response is added.

If you can, start up the old 8i database and see if the application connects to it. That way you’ll at least know if something is still looking for the old one or if the error is caused by a misconfiguration with the new one.

Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Charliep
    also check if you have more than one tnsnames file on the server. It has been a while since I used Oracle application server but there could be a registry (or some other) setting that is still pointing at another tnsnames.ora file. You did say that you are using the same database name for the new one as the old one.
    0 pointsBadges:
  • 108108
    Thank you all. The problem was solved. We have several Oracle home directories .. not under the same parent directory so 1 of them still was pointing to the previous server and we missed that one (in the tnsnames.ora).
    0 pointsBadges:
  • Oracledba55
    HI can you tell me the OS.This error related to Kernel parameter have you set the kernel parameters. If you set the kernel parameter definitely it solves your problem Regards, Sathish.R Oracle DBA
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: