Specific site access issues with Java Runtime 6 through proxy

2190 pts.
Proxy servers
I am a contractor new to this particular company. One of the departments in my production environment requires JRE to access a specific financial website through our proxy server. With 17 of 19 clients (WinXP SP2 fully patched), access is OK - no issues. With 2 of 19, the financial website (internal bank website) cannot be accessed: the required Java applet attempts to load, stalls, re-tries and eventually times out. We are running through a proxy server located overseas. When the proxy NAME is specified in the Java control panel, the site cannot be contacted at all. When the proxy IP address is specified, the two clients can connect, but the applet times out, as described above. We have uninstalled Java and re-installed without a solution. After a successful Java installation, we can verify operation from the Sun website (the "dancing java dude" is loaded). I have suggested two possible options to the house techs:
  1. Try to downrev the Java installation to JRE 4 or JRE 5
  2. Flush and re-register DNS
Has anyone seen this issue before and if so, how did you resolve it? Any/all comments are welcome.

Answer Wiki

Thanks. We'll let you know when a new response is added.

If I understand it correctly, 17 out of 19 don’t have a problem.

First make sure you have the latest IE/OS patches

Make sure you’ve set up the jre proxy correctly here.

Next determine where your jvm is trying to connect use “netstat -vb”

Some IE versions don’t pass their proxy info back to the OS properly. If you notice the java.exe trying to connect to the website directly, instead of the proxy, try to force it via the “proxycfg” command. First type just “proxycfg” to see if there is anything there. If there is, do a “proxycfg -d” to delete. If not, do “proxycfg -u” to copy IE’s settings or ” proxycfg -p <proxy-server-name>” to add it manually

If none of the above work, you can download the JDK with debugging tools on one of the machines and use it to see what exactly is failing.

Hope this helps.

Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Buddyfarr
    What type of proxy are you using? is it an ISA filter? we are using ISA and had the same issue. if we changed their proxy to our old SurfControl proxy it worked fine. as soon as we went back to the newer surfcontrol that worked with ISA server it stopped working. it is a problem with the Java. I will try to find out if there was ever a fix for it.
    6,850 pointsBadges:
  • Buddyfarr
    I spoke with my boss just now and we never did find a resolution to the problem. Ours was a direct issue with ISA server but since that employee does not work for us anymore we did not follow it to conclusion. Sorry!
    6,850 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: