RPC over HTTP problem and Exchange, RPC ping error 12175

Application integration
Microsoft Exchange
Microsoft Exchange 2003
Microsoft Windows Server 2003
Windows tools/WSRM
Hi all, I'm having a problem with a small amount of the clients that use RPC over http for Exchange 2003. Before I carry on, I have all the correct configuration (XP SP2, Exchange 2003 SP1, outlook 2003, etc..), and I know it works becuase most clients do work. I am now reduced to using RPC ping to find out what's happening. I have Exchange 2003, server 2003, on one server (not a DC) and it setup with SSL. The clients that connect ok, ping ok with rpcping. Those that don't work with outlook and therefore rpcping, can even use SSL by accessing webmail (https:mailserverexchange). The error I get from rpcping is Error 12175 returned in the WinHttpSendRequest whic says the certificate isn't trusted, however, I check the individuals explorer certificates and they are trusted. Microsoft suggest re-installing the certificate(KB822594), but why should I if most clients work, why shouldn't others?? Someone out there must have experienced the same problem! Thanks in advance for any help, Rob.

Answer Wiki

Thanks. We'll let you know when a new response is added.

have you made sure that these clients show up in your global address lists? if they do not then the rpc/http authentication may never work, i ran into this problem many times.

also what about setting up another exchange profile on 1 of the working machines with a client account in question, see what response you get.


Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Greenie
    Try copying the certificate from a working client to one of the non-working clients. I had the same issue and that worked for me.
    0 pointsBadges:
  • Rgoulding
    Hi, Thanks for your help. I found that removing certificates that shouldn't be there and import the ones that weren't sorted it. Cheers, Rob.
    0 pointsBadges:
  • Pollert
    I have the same problem - most users working fine but a few with this error. Can you tell me more about what certificates you had to remove/readd - thx
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: