ProC under Oracle 10g

10 pts.
Oracle 10g
Oracle 9i
Hi! I have a piece of code in Pro-C that's been running under Oracle 9i for several years. I recently compiled it using the ProC of Oracle 10g and the code complied without any problems. However, when I run it on an Oralce 10g database, queries that returned thousands of records in 9i return empty record sets in 19g. I ran the same queries in SqlPlus and got the expected results. Note that the query is a simple select with a single join statement. Does anyone have any idea what might cause this? thanks, Ilan

Answer Wiki

Thanks. We'll let you know when a new response is added.

It would help if you would post your code. Knowing which tables are being accessed, and the syntax of the query could help diagnose the problem.

I assume you copied and ran the query and it works outside the Pro-C routine.

Things that usually cause behavior problems between versions (with “no” code changes) are:

* Unicode changes – does your code use parameters or other variable structures which cause a non-Unicode to Unicode character comparison (such that it fails). This is particularly true of passed-in parameters. If you run your query with embedded literals and it returns the results, but fails when run in the compiled Pro-C module using dynamic parameters, this may be a Unicode conversion problem.

* Security/authorization – is your Pro-C routine executed with a different privilege set than when you run the query directly? (You “should” be able to test this by running the query and the call to the Pro-C routine from SQL*Plus (or your favorite environment)).

* Queries against SYS or DBA views (security related – sometimes the default access privileges to these views changes between versions).

As Oracle systems evolve, Unicode and Security are two areas that tend to change between versions.

Discuss This Question: 1  Reply

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • carlosdl
    I agree with Kccrosser, it could be helpful to see your code. Also, tell us if you ran the query from sql*plus with the same user than when it fails (Pro-c). Regards,
    85,865 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: