Problem opening a downloaded zip file in winzip 9.0

5 pts.
Tags:
WinZip
Zip Files
We are using ZipOutputStream for downloading a zip file. I'm having problems in opening this zip file in winzip 9.0 but the same file opens fine in winzip 8.0. But when I write the same file using FileOutputStream and ZipOutputStream into the server that file opens fine in Winzip 9.0. The error I'm getting is "Start of central directory not found:zip file corrupt. Possible cause: File transfer error" When I try to fix the problem using the Winzip command line Add-ON, it fixes the problem by saying the file has "extra 12 bytes at beginning of the file" What could be the reason for having this extra 12 bytes only when I do a download but not when i write it into a file. Please help me if you have any information on this. Thanks

Answer Wiki

Thanks. We'll let you know when a new response is added.

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • carlosdl
    Since you mention streams, I assume you are doing this by code, from an application.

    What programming language are you using?
    Can you post your code?
    84,505 pointsBadges:
    report
  • ToddN2000
    Sound like the path used for the stream may be off. Can you post the code like Carlosdl suggested? That we we can get a better understanding of your issue.
    104,075 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: