ORA-02068 and 03113

25 pts.
I have dblink in local database pointing to remote database 9.2. There is a view in local database which is based on tables on remote database using dblink. When I run the select on that view, it fails with ORA-02068 and 03113. It works intermittently. It works most of the time with less records but fails with more records.

Answer Wiki

Thanks. We'll let you know when a new response is added.

These errors are usually the result of a network problem.

Have you checked if the remote database is up and running at the time of the failure, and if the network connection of the remote machine is working as expected ?

We had a similar problem some time ago, but the two databases resided in different networks, and a device between them was causing the problem because of a ‘time out’ setting it had.


Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Skkumar
    Hi, The remote database is always up and running as they are production systems. The local database (dev and test environment) is for datawarehouse, which reads from the remote (production) source transaction system. The local db also reads from other two remote production database's in a similar way successfully. The local and remote db are on different network, test net and production net. The source BI_SRC_IFS and BI_SRC_UNI works fine. BI_SRC_IFS = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP) (Host = = 1526)) (CONNECT_DATA = (SID = master2) )) BI_SRC_UNI = (DESCRIPTION = (ADDRESS_LIST = (ADDRESS = (PROTOCOL = TCP)(HOST = = 1521)) ) (CONNECT_DATA = (SERVICE_NAME = uniplan) ) ) The BI_SRC_MAG gives connection failure error. BI_SRC_MAG = (DESCRIPTION = (LOAD_BALANCE = OFF) (FAILOVER = ON) (source_route = Off) (ADDRESS = (PROTOCOL = TCP) (Host = (Port = 1521)) (ADDRESS = (PROTOCOL = TCP) (Host = (Port = 1521)) (ADDRESS = (PROTOCOL = TCP) (Host = (Port = 1521)) (CONNECT_DATA = (SERVICE_NAME = WMSMAG)) (FAILOVER_MODE = (TYPE = SELECT) (METHOD = BASIC)))) ) I have also tried with below option but no success. BI_SRC_MAG = (DESCRIPTION = (ADDRESS = (PROTOCOL = TCP) (Host = (Port = 1521)) (CONNECT_DATA = (SERVICE_NAME = WMSMAG)) ) As you can see all the three sources are on same host, so I am not sure whether its really a network issue or OS issue or something to do with WMSMAG database. I have been working on this for many days with Oracle support and our internal network specialists, but no luck yet. I badly need help and need to resolve this. Regards, Selva
    25 pointsBadges:
  • Skkumar
    It seems to be working now, I have changed the port to 1526 in tnsnames.ora
    25 pointsBadges:
  • carlosdl
    Good news. Thanks for telling us.
    85,055 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: