Oracle error messages
Redo logs
What's the quickest way to resolve an ORA-00257 error? What are some ways to prevent this from happening?

Answer Wiki

Thanks. We'll let you know when a new response is added.

ORA-000257 is the “archiver stuck” error. If enough space is available, this will not happen… in a perfect world….. Based on the activity of the database and the amount of free space I have been able to allocate to archived redo logs, I have scheduled the logs to be written to our offline backup mechanism and then removed from the file system(s) at different time intervals. This can be done whether you have a single location or multiple locations designated for archived redo logs. In a UNIX environment, it is straight forward to write a shell script which can perform the backup and then use cron to schedule the script to execute. In a Windows environment, a bat file can be written to perform the same types of actions and then scheduled via the Windows scheduling system. I have the luxury of using TSM backups which has a “deletefile” option when the file has been successfully written to backup. This provides a sense of reduced risk that the file is restorable in case a recovery would be needed.

In your environment it may be necessary to work with your backup and restore team and maybe your System Administrator to accomplish a similar activity. If no offline backups are available, then available disk storage will be needed to avoid the error.

I didn’t realize that someone else had submitted another answer while I was typing this one. But, they had a couple of points that I missed. 1) be sure that automatic archiving is turned on in case you are getting stuck by lack of archiving. and also 2) after each database backup be sure to remove at least part of your archived redo logs as part of your general cleanup process. You may choose to keep a certain portion of your redo logs online to facilitate quick recovery if needed.

Discuss This Question: 1  Reply

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Aidrugo
    Hi, I am working with a new adsl managment platform, today customer reported no call center user were able to login to the HNM server (this is a Motive Server). Neither my login and password as admin or root were working in fact they dont work so far. The thing is, once I tried to access to SQLPLUS database(this is a Oracle db) I got same error above reported: "ORA-000257: archiver error. Connect internal only, until freed." Under `this web site got a little more description of this matter : http://ora-000257.ora-code.com/ Cause: The archiver process received an error while trying to archive a redo log. If the problem is not resolved soon, the database will stop executing transactions. The most likely cause of this message is the destination device is out of space to store the redo log file. Action: Check archiver trace file for a detailed description of the problem. Also verify that the device specified in the initialization parameter ARCHIVE_LOG_DEST is set up properly for archiving. So I think db has run of space out, but I dont know where to look for or what I must delete if I have to delete or what?. Where these redo logs are supousted to be in? Also how to make a backup of data base and where it's save by defalut? Please if some can give a hand I will fully appreciate it Thx Alv
    10 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: