Operating System not found (but worse than usual)

30 pts.
Microsoft Windows XP
Operating systems
Windows XP Professional
I work in IT Tech support (Hardware & Networking) so have a fair bit of knowledge and experience but this one has really got me stumped.

I got a tower running XP Pro on IDE 0 with DVD RW and on IDE1 I got 2nd data HDD. Both are Maxtor drives. It’s a fairly old machine but serves its purpose until recently. My BIOS is loosing my hard drives intermittently and I get standard message “Operating System not found” I pretty much think I have tried absolutely everything to fix it. Here is a list of some of the things I have done.

Checked and swapped CMOS battery (twice) but the date and time always remain correct as well as settings it is only the drives that go missing

Checked all mobo and HDD jumpers, swapped out IDE cables numerous times plus a new PSU for good measure

Tried all BIOS settings methodically

Run XP recovery console for following commands: chkdsk /r fixboot fixmbr bootcfg I have reinstalled XP both repair and clean install.

I suspected one of the HDD was failing so I ghosted both drives to new drives and run chkdsk on the new ones and I have run extensive Maxtor HDD diagnostic tools on the drives all say they are fine apart from 1 invalid partition so I ran partition magic and made my primary partition active.

I ran fdisk formatted and repartitioned my boot HDD then installed XP again

My HDDs are set to auto find in BIOS but I do not know the manual settings as they are not written on the drive casing. I would like to manually key in the heads, cylinders, LBA etc rather than leave on auto and I found Maxtor manual for drives but only LBA settings listed and it was a huge tech manual for it.

I flashed my BIOS to the newest available (it is an old Phoenix BIOS on a emachines mobo for Hewlett Packard) I want to get hold of previous version and flash it back but none are available anywhere on net they are listed but dead links only currant link is live (I spent many days searching)

Now then its not all doom and gloom but my only saving grace is that, at least, I can get the machine to boot. I have to switch PSU off and unplug power to all drives then boot. When it fails I switch power again, plug all drives back and F1 to BIOS setup then it finds drives I exit saving changes and it boots to XP with both HDD and DVD drives. Next time I boot I get same OS not found error and have to repeat the whole thing again. Please someone come up with something new I am loosing my hair rapidly!


Answer Wiki

Thanks. We'll let you know when a new response is added.

Based on your troubleshooting steps it sounds like the IDE controller is failing. You might be able to add a replacement IDE card if you have an available PCI slot.

Discuss This Question: 1  Reply

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Decay
    Thank you that is a good Idea. I have never used a PCI IDE controller in this situation as a primary IDE channel only ever used to expand storage options in the past. I have ordered a card hopefully it will be here tomorrow. I am a bit worried about my BIOS and XP detecting my HDD as primary IDE0 and IDE1 even if I disable my onboard IDE controllers. The BIOS is not the best I have worked with. Certainly worth a try and at worst if it doesnt work I can find a very good use for the card elsewhere. I have just remembered when and how the problem started. I once forgot to remove my USB flash drive and it has started giving OS not found since that time. The USB drive is now out and I have disabled boot from lagacy USB device in BIOS. I still think the problem is software related purely because if I make the hardware changes I described I can boot every time without fail and everything works fine. Almost like I am forcing the system to find new hardware everytime. Im also think the BIOS is at fault somewhere. I have also noticed that my boot sequence changes when I finally get the system to boot. The only think I know for sure is that all this unplugging and replugging is doing no favours for my mobo connections or HDDs.
    30 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: