Microsoft Sequel Server 2005 VSS backup

140 pts.
SQL Server 2005
SQL Server 2005 backup
SQL Server backup
SQL writer
Volume Shadow Copy Service
Windows Server 2008
What's seems to have happened is that the SQLVDI.dll files in the 2 directories: C:Program Files (x86)Microsoft SQL Server80COM C:Program FilesMicrosoft SQL Server80COM are out of sync. This seems to have happened as a result of a service pack for MSSQL which was applied in Dev. The Microsoft Sequel VSS writer is unable to initialize correctly and as a result of this interface not functioning properly, SQL Backup is unable to initialize. In order to get the versions of the SQLVDI.dll in sync again I copied the latest SQLVDI.dll from another server unregistered the out of sync version and reregistered the matching version. The SQL Backup service failed to start. This problem is on Microsoft Sequel 2005 SP2 running on Windows Server 2008 on Windows Hyper V platform. Microsoft released an untested patch for this problem, however, it says that the patch is not applicable when I attempt to run it on the system. I then put everything back as it was (out of sync) and the service runs but cannot backup or restore. By completely uninstalling Microsoft Sequel server including workstation components, VSS writer, Database Engine, Integration services and Full Text search engine, Red Gate Backup and then deleting all folders relevant to these installations, rebooting and reinstalling everything again, solves the problem. An uninstall of just the Database engine and Red Gate Backup does not solve the problem. Anyway, uninstalling everything isn't a solution. Have uninstalled and reintsalled VSS writer by itself. I've tried everything and nothing. Even tried to switch the reg key enabling VSS SQL Writer in an attempt to get it to use MSDE writer instead and no go. I'll try anything at this point...

Answer Wiki

Thanks. We'll let you know when a new response is added.

Error is caused by Red Gate SQL backup…

Log Name: Application
Source: SQLVDI
Date: 2008/11/13 01:34:57 PM
Event ID: 1
Task Category: None
Level: Error
Keywords: Classic
User: N/A
SQLVDI: Loc=SignalAbort. Desc=Client initiates abort. ErrorCode=(0). Process=2736. Thread=3552. Client. Instance=. VD=Global\SQLBACKUP_3DC515A5-DA6B-4603-AF45-F00EAABBE202_SQLVDIMemoryName_0.
Event Xml:
<Event xmlns=””>
<Provider Name=”SQLVDI” />
<EventID Qualifiers=”0″>1</EventID>
<TimeCreated SystemTime=”2008-11-13T11:34:57.000Z” />
<Security />
<Data>Client initiates abort</Data>

Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • LeonT
    I can do a native backup...
    140 pointsBadges:
  • Denny Cherry
    Are you running SQL 2000 or SQL 2005? In the tags and question you put SQL 2005, but the files that you referenced as the VDI files are SQL 2000 files. Are you running 64bit or 32bit? Do you have the correct build of RedGate installed? Have you contacted RedGate support to see what they say?
    69,145 pointsBadges:
  • Melville
    But what if I don't have another server unregistered? Where can I find this dll file extension? I run a SQL 2005 at 64bit. I don't know if I have correct version of RedGate installed, but someone told that this error has nothing to do with this.
    20 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: