JavaScript Error Through a VPN Connection

1200 pts.
Internet Explorer 8
Javascript error
Hey all, I am having an issue with a data repository we set up to be accessed inside the company and for our affiliates outside through the use of a VPN. Now the site loads fine using the local address inside the network but when someone remotes in through the VPN site the page just shows the navigation buttons but no data. It just displays blank fields where folders should be and the bottom the page says Errors on web page. Says its a Code 0 with a .js file. Any suggestions would be appreciated. Webpage error details User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729) Timestamp: Mon, 8 Nov 2010 14:42:51 UTC Message: Expected ';' Line: 2652 Char: 5 Code: 0 URI: epi_lib_rmenu.js

Software/Hardware used:
cyberoam firewall

Answer Wiki

Thanks. We'll let you know when a new response is added.

Now Check Available Ports:

1. Click Start > Control Panel > Administrative Tools program group and click the option
for Routing and Remote Access
2. Go to the Ports tab and verify that all of the ports are being used.
3. Change the number of available PPTP ports to allow more connections.

Discuss This Question: 9  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • FrankTheTank
    I will check the ports but I obviously have internet connection as stated from before that I can load majority of the web page besides the data fields remain blank due to a java script error. After some research I have done it seems to be the coding the program we use is using have a problem decrypting through the VPN I contacted them to see if this is the issue or not.
    1,200 pointsBadges:
  • AndreaF
    It might be worth trying this using IE as well. I had many issues connecting to my company's VPN site, but had the issues cleared as soon as I switched browsers.
    11,330 pointsBadges:
  • 0422
    Very good site, where did you come up with the knowledge in this post? I'm happy I found it though, ill be checking back soon to see what other articles you have.
    35 pointsBadges:
  • FrankTheTank
    Knowledge from myself lol at work. But yes I tried Mozilla, IE 8, and Chrome and neither worked. That was like the 2nd thing I tried before i became stumped lol. But I did do a Mozilla's error reporting which showed me the script where the error occurred so hopefully I can show it to the company who wrote it and they can help me out. Also had some suggestions to check firewall settings and IIS settings ill report back if i figure this out.
    1,200 pointsBadges:
  • batye
    try other browsers to see if all gives the same error
    3,080 pointsBadges:
  • FrankTheTank
    As noted above tried that.
    1,200 pointsBadges:
  • Pjb0222
    Some issues from my work when running applications over VPN: 1. Is DNS Search Order handed out in the VPN identical to the work network (in DHCP for the VPN)? (Big sigh yet again.) 2. Are all references in the web page fully qualified (FQDN)? 3. If any short references (unqualified names) are in use does your work use WINS? Is WINS enabled on the VPN (in DHCP for the VPN)? 4. Any firewalls on the VPN or are all ports open? 5. Does the VPN tunnel itself restrict ports? 6. Is the VPN end points routable to the data sources or does all that proxy through the web site? 7. Any router (switch) rules (filters) that affect the VPN connection that could be restricting connectivity? 8. Are any of the lookups timing sensitive (common issue for remote users)?
    3,310 pointsBadges:
  • jhamn
    i suspect this has something to do with your network issue.. i had similar experience while working outside our office and found out that the wireless broadband that i am using was the one causing the problem.. when i tried our wired broadband, it works well..
    750 pointsBadges:
  • Mattemax80
    This problem occurs when you try to open even others web pages with JS from VPN or this error occurs only when you try to open only that page?Maybe you must clarify this point. You can publish the code of this script? Without any further details it's a difficult thing trying to solve your issue.
    40 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: