Installing Oracle 9i Standard Edition on Windows Server 2003 with Xeon CPU: Why does Java Virtual Machine fail?

95 pts.
Database Management Systems
Intel PC hardware
Intel servers
Microsoft Windows
Microsoft Windows Server 2003
Standard Edition
Windows on Intel
We are replacing an old NT 4.0 server with a new Windows Server 2003, the new hardware (a Compaq ProLiant) equipped with Intel Xeon CPU. The old server was running a couple of database instances in Oracle 8i Standard Edition, which we want/need to replace with the 9i version. The installation files for the relevant 9i edition are downloaded from, and expanded to directories named Disk1, Disk2 and so forth. But: Whatever way I try to launch the setup, it "dies" in a few seconds, either without any message, or with the message "Could not initialize the Java virtual machine. Program will exit!". For each try it creates a new set of setup directories in C:Documents and Settings.. I have searched Oracle Metalink for help, but it does not seem to address this problem directly (for this version and this platform). The Oracle download comes with its own JVM files. I have tried with those, as well as with more recent versions from Sun. No cure. Does any of you have experience or references that can help me solve this and get Oracle 9i up and going? Any hints on small stupid details it is too easy to overlook?

Answer Wiki

Thanks. We'll let you know when a new response is added.

I am in the process of doing a similar thing.
Installing Oracle EE on Win 2003. The box is 64 bit but the op system is 32 bit. So I am installing the 32 bit version of Oracle. In order to do this the recomendation was to add a patch to the Oracle Installation for the Oracle Installer itself.
See release note for Release 2 ( for Windows 2003 (32 bit).

Discuss This Question: 4  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Onilke
    This message just to inform you that my problem is solved: In this case the solution was to enclose the contents of the environmental variable CLASSPATH in quotes (and reboot) before reentering the SETUP.EXE at the root of Disk1 (with the expanded content of the three disks exactly as delivered from OTN). A classpath with spaces in it does not work well with OUI for the version. Thanks to DutchDBA for hitting the nail on the head.
    95 pointsBadges:
  • Oradba13
    It has been a while but in one instance I found that the fix that is recommended for installing 817 on P4 machines (Note: 131299.1) also works for 9i - even though 9i is not mentioned in the note. That fix is to copy the install disk (I have found you only need to copy the first one) to disk and then rename symcjit.dll (symcjit.dll.old for example) and then retry the install.
    0 pointsBadges:
  • Jkstill
    I have found this to be pretty common on Windows 2000, don't think I've yet installed Oracle on Windows 2003, so your milage may vary. Try this: open up a terminal services (RDP) connection to the server, and install it from that session. Oracle does not support this, but, it is the only way I have been able to install Oracle on several servers. I have been over this with Oracle Support, they were happy when I found a 'solution' and dropped the matter. HTH Jared
    0 pointsBadges:
  • Dhanderson1
    There is a simple fix for installing on Pentium 4 machines that may work for you. After you have expanded your files into the different directories, do a search for symjit.dll (I'm not 100% sure on the name but this is real close). Once you've found it rename it to symjit.old. Next run the normal setup. This has worked for me numerous times.
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: