IBM i Full backup no longer backing up IFS

15 pts.
Tags:
Backup
BRMS
IFS
Full backup usually completes fine with IFS backed up. This past month, the backup ends in error when IFS starts to back up and ends abnormally. Something is using IFS to cause this to abend apparently. What can cause this? Should I end the host servers prior to the backup takes place that will end the subsystems? Any help will be greatly appreciated.


Software/Hardware used:
i OS
0

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Discuss This Question: 8  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • TheRealRaven
    Something is using IFS to cause this to abend apparently.

    Every action you take on the system is "using IFS". The IFS includes all directories and libraries, all UDFSes, all network shares... it's hard to locate stuff that isn't part of the IFS; so every time you run any backup, something is "using IFS" even in restricted state.

    The "abend" isn't described in your question, though, so we can't give any answers. What are the error message IDs? When do they show up?
    33,610 pointsBadges:
    report
  • Splat
    What does the job log say?
    12,855 pointsBadges:
    report
  • ToddN2000
    There may be open connections tied to the IFS files. Some of these may stay open to improve performance. Is this a new problem? How is your backup being done? Is the system in a restricted state?
    129,440 pointsBadges:
    report
  • pdraebel
    I once had a simlilar issue with some IFS objects that were "Checked Out". Finding the objects and doing a "Checkin" helped. This had to be done with iSeries Navigator.
    7,545 pointsBadges:
    report
  • Maracas
    Sorry for the late reply here, guys. Well, what is happening is the batch time limit as set for the BRMS full backup is the cause of issue here. I am getting the message that the batch time limit on the ending of subsystems has expired. As such, I increased the restricted state time limit, but still not completing fully yet, so I will increase by another hour I am now also using the ASYNCBRING parm.

    I may be wrong in increasing the time limit, so can you confirm that I am doing the right thing here?
    15 pointsBadges:
    report
  • TheRealRaven
    We can't know if it's right or not without possibly a lot more info. Why the time limit expiring? Will subsystems not end?
    33,610 pointsBadges:
    report
  • ToddN2000
    Still could be a number of issues. Any additional information in the log that you can share may be helpful.
    129,440 pointsBadges:
    report
  • pdraebel
    You should take a look at what is still active in the subsystems BRMS needs to end. It could be some job or process does not get ended correctly.
    7,545 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: