I cannot use past 2GB of a 16GB thumb drive, why?

25 pts.
Thumb drive
USB Flash drives
Hi, I am using a generic thumb drive and cannot get any type of file to load up if it is past the 2 gig mark on the thumb drive. No matter what kind of file it is-movies, music, documents- it all will let me fill up until 2 gigs. To explain more clearly I put five 1gig movies on the drive. I can play the first 2 movies but the file is corrupt if I play past 2 gigs. Music is the same way. I have 20 songs on the drive and only the first 7 or so will play. Now I can fill up the drive completely and the files show up but only the first 2 gigs worth of data is un corrupted. I have tried formatting it and that also does not fix the problem. Also a friend told me that sometimes it is the number of files in the root and I needed to create a folder but alas that did not work either. Please someone help so I do not have to throw away a 16GB thumb drive!

Software/Hardware used:
Thumb drive, partition editor

Answer Wiki

Thanks. We'll let you know when a new response is added.

May be check the partition type you are using if you are using FAT 16 then you cannot copy more than 2 GB

FAT16 has a maximum file size of 2GB, and despite the much larger hard disk size supported by FAT32, the maximum file size only doubled to 4GB.

This may be a situation where the flash drive is faulty or “hacked” to show more capacity than it actually has available. Look at this external forum posting on what one user did to repair their “hacked” USB flash drive. Note that the tips/tricks it recommends are not for the faint of heart or new computer users. I did use a similar process though on a USB drive I received. It had some demo security software on it that I was unable to remove by any other method. It cleaned the drive right up and I was able to use the full capacity.

In the IT trenches? So am I – read my IT Trenches blog

Discuss This Question: 6  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Technochic
    What is the operating system of the PC to which you are connecting the USB drive? Have you called the manufacturer for assistance? Is it still under warranty?
    57,010 pointsBadges:
  • Nixmix182
    I am using FAT32 and have not tried putting anything over 4GB on it. I Have tried to switch it to NTFS but it comes back with an error in the partition. I have tried doing this on xp and ubuntu and still cannot figure it out. Also as I said before it is a generic drive so I cannot call up a manufacturer or get a replacement. Thanks for the responses and I hope that we can solve this.
    25 pointsBadges:
  • Pjb0222
    You can test the memory stick to determine what you have. There are many "fake" memory devices floating around. This is one available testing application. http://sosfakeflash.wordpress.com/2008/09/02/h2testw-14-gold-standard-in-detecting-usb-counterfeit-drives/
    3,310 pointsBadges:
  • Labnuke99
    A good article about repairing/reflashing a USB flash drive process can be found here.
    32,960 pointsBadges:
  • Satechheads
    you might try this it has worked for me. bryan http://www.ntfs.com/quest22.htm
    10 pointsBadges:
  • Nixmix182
    Yeah I finally figured out that the drive was a fake. Got my money back and only wasted my time. Thanks again for all the helpful discussion.
    25 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: