HTTP *Admin server is not starting

925 pts.
Tags:
AS/400
HTTP
Hi Team,
Our HTTP Admin server is not starting up. We have deleted and restored the 5770-DG1 licensed program, upgraded the PTF level to 35 but none of them proved useful. Please find the below log and provide your suggestions.
NOTE : We have installed six PTF's SI58618, SI60810, SI62167, SI62173, SI63909, SI63912 recently. We have removed the PTF's and tried to start the server but it didn't start.
Job Log:
              Job Log                             POC01    21/03/17 12:00:11          Page    1             
ADMIN           User  . . . . . . :   QTMHHTTP     Number . . . . . . . . . . . :   279294                  
QZHBHTTP        Library . . . . . :   QHTTPSVR                                                              
SEV  DATE      TIME             FROM PGM     LIBRARY     INST     TO PGM      LIBRARY     INST              
00   21/03/17  11:59:44.113490  QWTPIIPP     QSYS        04C0     *EXT                    *N                
  Message . . . . :   Job 279294/QTMHHTTP/ADMIN started on 21/03/17 at 11:59:43                             
    in subsystem QHTTPSVR in QHTTPSVR. Job entered system on 21/03/17 at                                    
    11:59:43.                                                                                               
40   21/03/17  11:59:47.073166  QSVTCMMNH    QHTTPSVR    *STMT    QSVTAP22LF  QHTTPSVR    *STMT             
  From module . . . . . . . . :   LIB_UTIL                                                                  
  From procedure  . . . . . . :   pluginSendDiagToJobLog                                                    
  Statement . . . . . . . . . :   3                                                                         
  To module . . . . . . . . . :   MOD_WAS_AP                                                                
  To procedure  . . . . . . . :   as_post_config__FP10apr_pool_tN21P10server_rec                            
  Statement . . . . . . . . . :   28                                                                        
  Message . . . . :   WebSphere plugin initialized.                                                         
  Cause . . . . . :   This message is used by application programs as a general                             
    escape message.                                                                                         
10   21/03/17  11:59:54.456998  QZSRAPR      QHTTPSVR    *STMT    QZSRVSSL    QHTTPSVR    *STMT             
                                                                                                            
   From module . . . . . . . . :   QZSRSNDM                                                             
   From procedure  . . . . . . :   sendMessageToJobLog_CCSID                                            
   Statement . . . . . . . . . :   27                                                                   
   To module . . . . . . . . . :   MOD_SSL                                                              
   To procedure  . . . . . . . :   ssl_initializer                                                      
   Statement . . . . . . . . . :   150                                                                  
   Message . . . . :   Secure Sockets session failed to initialize successfully.                        
   Cause . . . . . :   Secure Sockets failed to initialize successfully. Recovery                       
      . . . :   Check the error log to determine the cause of the failure, and                          
     start the server again. Technical description . . . . . . . . :   Secure                           
     Sockets failed to initialize correctly.                                                            
 30   21/03/17  11:59:54.497322  QZSRAPR      QHTTPSVR    *STMT    QP0ZPCPN    QSYS        *STMT        
   From module . . . . . . . . :   QZSRSNDM                                                             
   From procedure  . . . . . . :   sendEscapeWithMessageFile                                            
   Statement . . . . . . . . . :   4                                                                    
   To module . . . . . . . . . :   QP0ZPCPN                                                             
   To procedure  . . . . . . . :   InvokeTargetPgm__FP11qp0z_pcp_cb                                     
   Statement . . . . . . . . . :   181                                                                  
   Message . . . . :   One of HTTP Server instance ADMIN jobs failed.                                   
                                                                                                        
    Cause . . . . . :   There are one or more jobs associated with the server                         
      instance ADMIN. If there are other server jobs active, they will continue                       
      processing requests and another job is also created automatically to replace                    
      the failed job. For more information, see the previous messages in the job                      
      log. Recovery  . . . :   Correct the problem identified in the job log.                         
  50   21/03/17  11:59:54.530754  QC2UTIL1     QSYS        *STMT    QZSRCORE    QHTTPSVR    *STMT     
    From module . . . . . . . . :   QC2SIGNL                                                          
    From procedure  . . . . . . :   raise                                                             
    Statement . . . . . . . . . :   6                                                                 
    To module . . . . . . . . . :   MAIN                                                              
    To procedure  . . . . . . . :   Main_Cancel_Handler                                               
    Statement . . . . . . . . . :   21           *PRCLT                                               
    Message . . . . :   Signal SIGABRT raised (abnormal termination).                                 
    Cause . . . . . :   The signal SIGABRT was raised to indicate an abnormal                         
      termination.                                                                                    
  00   21/03/17  11:59:55.871988  QSCPUTR      QSYS        005E     QMHAPD      QSYS        0504      
    Message . . . . :   Dump output directed to spooled file 1, job                                   
      279294/QTMHHTTP/ADMIN created on system POC01 on 21/03/17 11:59:55.                             
                Job Log                             POC01    21/03/17 12:00:11          Page    2     
 
 
Best Regards,
Gayathri
 


Software/Hardware used:
AS/400, IBM i, iSeries

Answer Wiki

Thanks. We'll let you know when a new response is added.

Check out appendix C of the PDF in this link, it may help.

It’s from the IBM Redbook.

Discuss This Question: 6  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • pdraebel
    I cannot tell from the excerpts of the joblog presented here, but I suspect some Authority Issues are at the base of your problem. probably user QTMHHTTP or QLWISVR do not have adequate authority to some part of the IFS. You may want to check this URL https://archive.midrange.com/midrange-l/201403/msg00730.html

    7,545 pointsBadges:
    report
  • ToddN2000
    If you are getting PTF's you must have IBM support. You could try them for a resolution. It might be quicker. We have had issues in the past with bad PTF's that had to be uninstalled. You may have a similar issue with the ones you recently installed or they are conflicting with something else.
    115,425 pointsBadges:
    report
  • Gayathri123
    Thank you @pdraebel and @ToddN2000 for your valuable input.
    925 pointsBadges:
    report
  • Gayathri123
    Hi,

    Followed the seven step process provided in the link and started the admin server, it did not work. And also we have removed the newly installed PTF's, it still didn't work. We have other three boxes where Admin server is working without issues after installing the same PTF's.


    Best Regards,
    Gayathri
    925 pointsBadges:
    report
  • Gayathri123
    Hi Team,

    Thank you. We have followed the seven step process, re-installed the PTF group and disabled the SSL configuration and the webpage is working fine now.


    Best Regards,
    Gayathri
    925 pointsBadges:
    report
  • TheRealRaven
    For future questions... It was difficult because the joblog portion of your question cut off the most critical parts -- the message IDs were missing, so searches wouldn't be as helpful. But the text "Secure Sockets session failed to initialize successfully" (possibly HTP8351) indicates the likely problem. Mostly, just posting "message ID HTP8351" in place of the whole joblog part would have been better.
    28,995 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: