How can I use mscal.ocx on a Windows 7 64-bit machine?

20 pts.
Microsoft Excel 2003
Microsoft Windows 7
Windows 7 64-bit
Hi there, I have some VBA code that works in Excel 2003. It references the calendar in mscal.ocx. Typically, when I've moved it to a new machine (XP, 32-bit), I've had to copy mscal.ocx there and run regsvr32 mscal.ocx and then everything works. But on a new, 64-bit windows 7 machine, with Excel 2003 on it, regsvr32 doesn't work for mscal.ocx. I get this error message: "The module 'mscal.ocx' may not be compatible with the version of Windows that you're running. Check if the module is compatible with an x86 (32-bit) or x64 (64-bit) version of regsvr32.exe" Is there any easy fix to this? Thanks! -Dave

Software/Hardware used:
64-bit windows 7 excel 2003 and mscal.ocx

Answer Wiki

Thanks. We'll let you know when a new response is added.

Actually, a bit more info. I was running regsvr32 straight from the “run” command line. If I run it from C:\windows\syswow64 I get a different error:

“The module c:\windows\system32\mscal.ocx failed to load. Make sure the binary is stored at the specified path or debug it to check for problems with the binary or dependent .DLL files.

The specified module could not be found.”

Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Mralaska
    I was getting the exact same errors when I installed a macro for a client yesterday running Office 2007 on Windows 7. It turns out the problem is with the new and improved security settings. The simple solution was to remove the security settings for the folder the file was in. After removing the security settings; the macro ran perfect and we did not need to install mscal.ocx. Unfortunately I do not have access to Windows 7 any more and I cannot recall the exact steps but the way I found the path to unlock the folder was by attempting to run another Excel file with a simpler macro that does not require mscal.ocx. The ensuing error in that case specified the real reason and provided a link explaining how to change the security settings. I hope that helps, Paul
    10 pointsBadges:
  • Snouss
    %systemroot%SysWoW64regsvr32 mscal.ocx I don(t know why it's ok but i tried it after i read this and it's working ?? :
    20 pointsBadges:
  • Snouss
    Re moi.. Sorry, I didn't say Hello ! and Bye... sorry I don(t speak english very well ! See You Bye
    20 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: