FTP Problem using Zmod

Protocol analysis
I have a problem running Zmod GETDBFFTP to retrieve files from a Unix box. Intermittently a character is being dropped from files retrieved. There seems to be no consistency to this. A file/data that has this discrepancy can be retrieved half a dozen times without problem. It is not particular to a certain file and neither does it affect all the data within the file. The problem has occured with a text file and a csv file, the csv file lost a comma whilst the text file lost a blank. The source data was verified and found to be without error. We are scratching our heads at present.

Answer Wiki

Thanks. We'll let you know when a new response is added.

I don’t normally deal with AS/400 stuff, but I wonder if you’ve tried using the BIN (TYPE I) mode for transfer of your files.

You mentioned a text file and a CSV file. They are BOTH text formats, CSV just means “Comma Separated Values”, but is still text.

While BIN is normally used for binary files of various sorts, it couldn’t hurt to try.


Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Lpgast
    I don't have an answer for you, but I guess I should feel better that someone else has this issue and it's not just me like trailblazer would like me to believe. When I send a file I'm losing characters. It's intermitent, but always seems to happen when there is a space at the 80 character boundary (for EDI files). This causes all sorts of errors with the QRS catalog. If you get headway into this, please let us know what you did to fix it. P.s. Changing to BINARY(that's what I use anyway) doesn't correct the problem.
    0 pointsBadges:
  • Ravisurya
    hi, i too faced the similar kind of problem while uploading csv files using sql loader in apps 11i. The problem was one extra chacter get appended to the last column's data of csv file. temporarirly i solved this problem by considering substr(colname,1,length(colname)-1). ie truncating last character of last column. if some one across this kind of problem and found solution to this pls let me know. thanks in advance.
    0 pointsBadges:
  • TomLiotta
    Note that using BINary for FTP text transfers between Unix and i5/OS would likely cause a lot of confusion and result in a mess. The ASCII/EBCDIC conversion wouldn't be done. It could be handled on the AS/400 side, but it takes a little preparation and an understanding of character encodings. Tom
    125,585 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: