File transfer to the iSeries problem.

Backup and Recovery
IBM iSeries
Logical partitions
PC/Windows Connectivity
Server consolidation
System monitoring
tips and tricks
I am trying to transfer an excel speadsheet file to my AS/400. I have tried setting up a file transfer through client access and tried sending the file directly from Excel. Both times I get the following error cwbtf0023 - pc file description file was not specified or is empty The file is not empty. Any suggestions? Also, through Excel I have tried numerous options like having it create the physical file and member for me on the AS/400 as well as the option of sending the info to a file already created on the AS/400. I continue to get the same error as above.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Do you have a drive mapped directly to the IFS? If so all you need to do is save it to there. No need to transfer files then.

Discuss This Question: 7  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • WaltZ400
    If you are trying to transfer Excel data into an AS/400 physical file, you need a PC description file on your PC to tell the upload how the columns and fields are laid out. First create the PF on the AS/400 with DDS to define each field based on the columns in the Excel document. Next do a Client Access download of the AS/400 file down to your PC. Make sure you take the option to create a PC description file specifying the file name and folder to store it in. Run the download. Don't worry if you get a message saying no data transfered. All you are doing here is creating the field map file. Next, I always find it easier to save the Excel spreadsheet as a CSV file before uploading the data. Next, define an upload to the AS/400 specifying the CSV file you are copying, what AS/400 file to send it to and what the name of the PC description file is. Make sure you define the input PC file as a CSV in the upload. Then run the upload. If all goes well the data should be in your PF on the AS/400. You might need to experiment as I have had problems sometimes with dates etc. since Excel stores these as offsets. Hope this helps.
    655 pointsBadges:
  • Bkr0963c
    Thanks guys. I was able to get it to work.
    0 pointsBadges:
  • johnknight
    Just another note, if you use the file transfer wizard in Client Access, it will analyze your spreadsheet & create the file description on the fly. It's customizable & works very well.
    0 pointsBadges:
  • Das149
    Hi There, I’M HAVING A PROBLEM WITH THE NEW UPLOAD. THIS MESSAGE APPEARS ON THE SCREEN "CWBDB0044-Native Database file server returned error. CPF9801- Object A in Library ALIB not found. Cause- The object A in library ALIB type *FILE not found" Could you please suggest me. Thanks in Advance
    10 pointsBadges:
  • TomLiotta
    The error says: CPF9801- Object A in Library ALIB not found. Cause- The object A in library ALIB type *FILE not found Create the appropriate file named A in the library named ALIB. Then try the upload again. Your procedure is expecting that a file named A already exists in ALIB. That's a direct answer, but it might not be right for you. You should verify that the correct option is selected for the upload. Look at the window that opens when you click the 'Details' button on the transfer window. Check the "Create iSeries object" option to be sure the right one is chosen. Tom
    125,585 pointsBadges:
  • Cat2010
    Hello- I have uploaded an excel file into my IFS saved as CSV and it's not readable in the iseries..../Any Help?
    55 pointsBadges:
  • philpl1jb
    I think it would be better if you started a new thread and add some more info into the question.. 1. How are you trying to access the file on the AS/400? What happens? 2. Are you certain that you saved it as a CSV in excel? 3. Did you close Excel - so the file won't be locked? 4. Can you read the file with word pad or note pad? Phil
    54,090 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: