Error message when creating a stored procedure: SPxxx is created but cannot be saved or restored

Tags:
AS/400
Stored Procedures
I created a stored procedure on AS/400, the message in return was 'SPxxx is created but cannot be saved or restored '. I am able to view the created stored procedure in the Library but when I call the procedure the error message was 'SPxx was not found with specified parameters". How to resolve the error?


Software/Hardware used:
as400
1

Answer Wiki

Thanks. We'll let you know when a new response is added.

What library was it created in and id that library in your LIBL? It may also be an authority issue. Check the profile used to create the SP and object authority. It may be the user does not have the proper authority to use it.

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Splat
    Have you reviewed the lower-level messages preceding the above in the job log?
    12,835 pointsBadges:
    report
  • CharlieBrowne
    With the information you gave us, the error is telling you that the parameters you used to call the store procedure do not match what the program is expecting, Could be the wrong number of parms, wrong sequence or alpha/numeric issue.
    62,385 pointsBadges:
    report
  • BigKat
    if you were trying to overload the stored procedure with different parameter lists, you need to add the SPECIFIC option to the CREATE PROCEDURE command and give each option a unique name

    SPECIFIC name_10chr
    9,410 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: