Error info… 00 671: ABAP/4 processor: SAPSQL_ARRAY_INSERT_DUPREC

When somebody posts something in FI (FB50), SAP seems to normally post it (It says on bottom e.g. "Document 100000008 was posted in company code 1000"). However, as soon as we continue working a message appears saying: "Express document 'Update was terminated' received from author {Name of person who posted}". Then in the SAP Inbox of the user, there is a message saying that the update was terminated with Error Info: "00 671: ABAP/4 processor: SAPSQL_ARRAY_INSERT_DUPREC". When we check, no account has been updated and the system wouldn't find document 100000008. We are working in SAP 6.4 on a sandbox with IDES and haven't changed much on the system. Does anybody have a clue what this means and how it can be fixed?

Answer Wiki

Thanks. We'll let you know when a new response is added.

The problem is with the number ranges. The error, SAPSQL_ARRAY_INSERT_DUPR, displayed states that a insert was being tried with a document no already existing. Kindly check up the number ranges


Discuss This Question: 4  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Cfilandro
    When you process your FB50 transaction, SAP runs through all of the 'business logic' (for example all your config, any ABAP userexits, master data checks, etc). The next available document number is displayed to you on the assumption the document will be successfully added to the DB. After that, SAP passes all your document's information to the 'update task'. This process merely does the DB inserts, deletes, modifys. If there is a problem within the update task when posting a document, the DB does a rollback. That is why your Document Number is not found...the insert into the DB failed. You can troubleshoot via st22, sm21, sm13. It could certainly be a problem with the number range as Itseduardo stated above. But it can also be due to other problems. You can also use the info from the transactions to search for solutions in OSS. Good luck.
    180 pointsBadges:
  • Sapnerd
    I had same problem when I was posting AP invoice in FB60 and was given the same error message '00 671: ABAP/4 processor: SAPSQL_ARRAY_INSERT_DUPREC'. The solution I had was - - Go to T.code: KANK to check the number in the 'Current number' column; - Then go to T.code: se16, Type in 'cobk' to check the last Co.(Controlling) document number within one range. E.g. 200000015 is the last document number in number range '0200000000 ~ 0299999999'. - Update the last co. document number read from table 'cobk' in KANK. - Try FB60 again. Hope it helps.
    10 pointsBadges:
  • Rsr
    Am also facing same problem..i did as said above..but still my problem is not solved. pl can any one help me out..
    10 pointsBadges:
  • P1058786
    I had the same problem when i was posting goods receipt, the problem is with the number ranges, either if the number ranges has reached the maximum limit or number ranges not maintained properly. I changed the number ranges and did Goods receipt it is working fine
    10 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: