Difficult SSH problem

20 pts.
Fedora 9
I have a remote server running Fedora 9. I control this server via SSH normally, though a similar problem occurs when I use vnc or sftp. The only way I can describe the problem is that it resembles a freeze or locking up of what ever session (ssh vnc or sftp) when I try to do most anything that requires significant amounts of data to be sent back to the remotely connecting workstation. It also is note worthy to mention that it happens with different client applications. Specifically SecureCRT and puTTY for SSH, and tightvnc and ultravnc for vnc. I first noticed the problem when I tried to edit the httpd.conf file, when I would navigate to and attempt to edit with either vi or pico the session would immediately freeze, unlike the time out problem described most often. I have tried to wait out the frozen session by leaving it connected to the server despite not being able to give the server new input. I am also NOT being disconnected from the remote server. The problem does not occur if I try to edit smaller .conf files such as pure-ftpd.conf, but does occur when attempting to view or edit httpd.conf. Similarly the problem with the session freezing appears when attempting to connect via vnc. I am able to display the login box, minus any text, only the grey enter your password box, the mouse is frozen and the server does not accept any input and does not disconnect me. I think the problem may be network related, but I don't know what specifically that could be, as the server operates without an error when used at the local console. I'm hoping someone can help me troubleshoot this issue as I've run up against a wall as far as ideas go.

Answer Wiki

Thanks. We'll let you know when a new response is added.

My first guess would be a corruption of something. Did anything happen when the problem first started (after an update or a new rpm install or something)?

Have you attempted to monitor any performance statistics while the problem is happening? Using the console start monitoring and then try to SSH in from a remote box?

If it was networking, in my experience anyway, it is probably speed/duplex mismatch or something causing a lot of errors (bad network cable, switch port partial failures, etc). I would verify the speed and duplex and then if possible check the error counter on the switch port. You may also try a brand new network cable into a different switch. If there is a physical problem outside this box, this solution would eliminate those instantly. You can then troubleshoot in order to find the specific problem.

If the problem persists despite a new network cable and a totally different switch, then try a detail hardware diagnostic. Most brand name servers and workstations have some kind of hardware testing utility you boot up to and test everything.

If all that fails, I would go back to my original guess of a software corruption of some sort. You can try repair utilities, a restore to a known good time, or reinstalls over the existing but in my experience, the most reliable answer is a fresh build somewhere else and then a transfer of essential files only.

Hope this helps.



Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • carlosdl
    The problem also occurs if you connect using ssh from the console of another linux machine ? I mean, without using puTTY or any other client software ? I would try making the connection in reverse, from that server to some other machine, and see what happens if you exchange considerable amounts of data.
    85,390 pointsBadges:
  • IT Knowledge Exchange Community Update for 12/18/08 - ITKE Community Blog
    [...] >> Difficult SSH problem [...]
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: