dialup socket or config issue

Microsoft Windows
I have a XP pro station that uses dialup for external networking in a rural area. Recently I tried System mechanic 6 for a day and it really did a number on my system. I had to uninstall it manually and do a repair install of xp to get everything back. I didn't lose any data thankfully. The only thing not working is the browsers. The connection will dial up and I get an icon in the tray. It says connected in network places when I look at the dial up connection but the browsers cannot open any pages. I have tried with IE, Opera, Firefox, hotjava and Avante. all the same. When I use "ipconfig /all" I get a valid set of ips for my isp. I ping the DNS server and get giberish in the top line saying "pinging #$^% with etc,." instead of pinging X.X.X.X where x are the ip numbers I entered. I have looked through services to see what might be off that should be on but no luck. Finally I installed XP again in another folder as a multiboot and the new install works great. Networking is al should be. How can I fix the old install so I can remove the multiboot and go back to the way it aught to be? I feel like the answer is right in front of me and I am not seeing it. Thanks

Answer Wiki

Thanks. We'll let you know when a new response is added.

I have seen simular in older OS’s and it was due to a corrupt TCP/IP stack. With newer OS’s you can not uninstall and reinstall the stack though it can be reset. Please see http://www.mcpmag.com/columns/article.asp?EditorialsID=1400 to reset your stack.

Discuss This Question: 4  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • JCDignoti
    You could try doing a system restore from a date prior to installing System Mechanic. You can find it under All Programs> Accessories>System Tools>System Restore.
    0 pointsBadges:
  • DigitalNomad
    I'm also going with a corrupt ip stack. You might also want to check your system for new.net spyware in add remove programs. The adware agent would replace the windows ip stack with it's own...both removing and replacing the microsoft drivers in system restore and drivers cache. Removal would corrupt the IP stack and present the same symptoms you mentioned. Regardless of which, you can use this nifty utility to remove the ipstack and antomatically reinstall via your i386 cab files. Disable system restore before running. The utility is called winsockxpfix.exe and is available at http://www.snapfiles.com/get/winsockxpfix.html. It belongs in every techs toolkit. Also, don't forget to rerun the latest service pack and updates on your system. Good Luck Jeff
    0 pointsBadges:
  • bmarone
    Few things: 1) Recommended sing NETSH to fix the stack seems straightforward, but you might theoretically fix a corrupt stack thru the GUI from the NIC properties, unchecking the "Internet Protocol (TCP/IP)", committing, and then rechecking it. 2) The reply #3 mentions the link, should be http://www.snapfiles.com/get/winsockxpfix.html but link doesn't work since a period got appended. 3) Hadn't seen "Winsock XP Fix" program, but I've successfully used LSPfix for the same thing. Link is "http://www.cexx.org/lspfix.htm" or you can Google "lspfix" or "fix winsock". As mentioned, you need to do this is malware is injected into the stack. Resetting the IP stack in #1 may not remove malware, as it may inject itself again as a valid LSP.
    0 pointsBadges:
  • Dwiebesick
    If you want to use the NETSH command here is the syntax netsh winsock reset catalog Reboot your system. If still having problems, follow up with this command netsh in tip reset c:iplog.txt The c:iplog.txt is just a file the netsh will use to place its log file and can be any name. Best of luck dmw
    2,235 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: