DHCP Server provides Wrong Subnet

115 pts.
DHCP server
Our company had a hub and spoke network for years, a single server room supporting 20 remote locations, most using the Citrix farm.  We grew and started a second server room.  At the second location we have a switch stack of 9 Cisco 3750 10/100 switchws setup with 5 VLANS.  previously IP addresses in the new location were provided by a DHCP server in the hub location, a different subnet than is in the new location.  We setup a DHCP server that is in one of the five VLANS in the new location and that is when the problem started.  Most of the time a system cannot be moved between offices without failing to pick up an IP address if the wall port is a different subnet.  For example, if the system was in subnet .65 and is moved to a location where the subnet is .66, the system still picks up the .65 IP address and cannot communicate with anything.  We have flushed DNS, deleted leases on the DHCP server.  Somehow when renewing the IP address the old address assigned to the system comes back.  We believe this may be related to having the DHCP server in one of the subnets, or one of the VLANS being served by this switch stack.  It does not haooen 100% of the time but seems to be more than 50%.  Any ideas or recommendations as to what might be causing this DHCP address probem?

Software/Hardware used:
Serevr 2003 R2 DHCP, Cisaco 3750 switches in a stach

Answer Wiki

Thanks. We'll let you know when a new response is added.

I am guessing that you just disconnect the machine and move it, without powering off ? I am also assumeing that the switches are configured correctly for the forwarding-address to the correct DHCP server,a nd that the scopes are correct on those DHCP servers.

If you move the machine, and do the following commands at a DOS prompt, does it then pick up the correct IP address ?


If it does, then the issue is that the machine is keeping it’s old address, rather than it getting the same one from the DHCP server. If you regularly move machines, then you may need to set the lease time down quite low. the disadvantage is that there is a lot more DHCP activity, which eats into the bandwidth, and ,makes the DHCP server work a lot harder.

You should really release the old address before moving the machine, then it will try to get a new one when reconnected elsewhere.

Hope that worked for you.

Discuss This Question: 4  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • D50041
    We always shut the machine down before moving; the setup in the Cisco switches has been checked and rechecked to confirm the forwarding to the DHCP server is set correctly. Threee other VLANS setup in the same switch stack do not have this problem, only the two I identified. We have done the release and renew repeatedly on some machines and the ones that exhibit the problem come back with the old segment, making them unusable. I have to believe it is something in the VLAns and switches, and nothing to do with the DHCP server.
    115 pointsBadges:
  • Labnuke99
    Some Windows client computers have a tendency to have "sticky" DHCP addresses that are very difficult to release/renew. In cases like that, you sometimes have to set a static IP and then restart and then set to DHCP to get a dynamic address. Have you updated NIC drivers and OS patches on these computers?
    32,960 pointsBadges:
  • ATECH1024
    I ran into the same problem and it was due to the way the Microsoft DHCP scopes were set up. When you have multiple IP segments on the same wire (Ex a router interface with 3 IP's) You create a Superscope with the different IP scopes under it. In the case where you have remote IP segments that are the source of your DHCP requests, and are using IP helper to get them across a router(s) to your DHCP server, you create individual scopes. (ie NO superscope).
    10 pointsBadges:
  • Sixball
    Sounds to me like you dont have the untagged traffic from the DHCP request forwarded to the proper DHCP scope for the VLAN you're trying to connect to...
    8,705 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: