Dell laptop NIC problems

65 pts.
Hi, One of my colleagues has a Dell Latitude D510 running Windows XP. When connected to our LAN, the laptop is unable to obtain an IP address. When I view the network card in Device Manager, it appears to be installed and working correctly. The NIC is a Broadcom 440x 10/100 Integrated Controller. I have de-installed, and re-installed it using the drivers downloaded from Dell's website (R92936.exe), but this has made no difference. IPCONFIG gives me an IP address of, the newtork icon in the system tray displays 'Limited or no connectivity'. It is set to obtain an IP address automatically. If I give it a manual ip address, I still do not get connectivity (I can't ping anything on the network). Any idea's what is causing the problems? Thanks Nick

Answer Wiki

Thanks. We'll let you know when a new response is added.

Based on your information it sounds as if the hardware is working correctly. Have you tried a different network cable that is working from another computer? How about plugging it directly into a working port in a switch on the network (eliminating the wall jack)?

Discuss This Question: 6  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Nickc1976
    I have tried connecting it using a different cable & network socket (which I know are working correctly) and still get the same outcome
    65 pointsBadges:
  • Tbitner
    Do you have a spare pcmcia NIC to try? Any software installed that could be interfering (firewall, vpn software, spyware)? Try resetting TCP/IP with the command line: netsh int ip reset c:resetlog.txt
    510 pointsBadges:
  • Jayjayjay68
    Hi This may sound silly, but is the Dell Latitude D510 connected to mains power ? If it is running on battery, by default the nic is disabled.
    0 pointsBadges:
  • Nickc1976
    Fixed it! I ran the command netsh int ip reset c:resetlog.txt Then I disabled then re-enabled the nic. This brought up a McAfee firewall message. McAfee firewall shouldn't have been installed on this laptop, so I removed it, and the connection is now OK. Thanks for the help
    65 pointsBadges:
  • Bobkberg
    And THANK YOU for posting the followup! Too many times we never hear back, and thus don't learn of the final results. Bob
    1,070 pointsBadges:
  • Egilmore
    Based on what I read it seems the issue you may have lies in the Dell Quickset Dell Quickset manages your NIC and the reason that may be giving you the issue(s) is because your NIC maybe turned off. You can turn on NIC using Dell Quickset power management application.
    350 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: