Debugging with WDSc?

WebSphere Studio
I am trying to use WDSc version 6 to debug iSeries programs but I constantly get an error telling me that the debug server has not been started on the iSeries host whenever I choose any of the debug features. Well, it is running! I've tried starting and stopping using the STRDBGSVR and ENDDBGSVR commands as well as right clicking a RSE subsystem and using the Remote Servers option there. The stupid thing is that when the debug server is running (jobs QB5ROUTE and QB5ROUTER running in QSYSWRK subsystem) and I try and do as the error message tells me (to right click one of the RSE subsystems and choose remote servers and start debug server) it tells me that the debug server is already running and only one instance can be started but debug launcher tells me it's not running and won't start. On the iSeries I'm running V5R2M0 at cummulative fix level 5123 just recently applied. The verify connection option checks out all OK. All required PTF's applied and debug daemon callback on port 8001 and RSE daemon callback on port 4300 all report OK. The debug server jobs are running and listening on ports 3001 (QDBGSVR) and 3825. My WDSc install has all the latest updates to Version: 6.0.1 Build id: 20050725_1800. I've also tried connecting to a V5R3 system at cummulative PTF level 5207 (verify connection all checks out here too) with the same result. This leads me to suspect it's something to do with the WDSc config. on my PC. I'm at a complete loss now as to why I can't start a debug from within WDSc. Why do I constantly get the message... "ISeries Debug Server has not been started yet. Please right click on one of the Subsystems in the Remote System View, and choose Remote Server -> Debug -> Start. Or, you can run command STRDBGSVR in your iSeries host." When the debug server is so obviously already running? Any help with this would be greatly appreciated. Paul

Answer Wiki

Thanks. We'll let you know when a new response is added.

It sounds like you’ve got everything set up correctly. I assume you have simply tried right-clicking on ‘iSeries Objects’ under a connection. From there, can you select ‘Remote Servers’, ‘Debug’, and ‘Start’? If so, try it. If not I would say it’s time to open a PMR with SupportLine.

Discuss This Question:  

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: