Copy and pasting cell in Excel 2002 to AS/400 application

10 pts.
PC/Windows Connectivity
I am trying to copy a cell with multiple lines of information in Excel 2002 and pasting it to input fields (horizontal input lines) in our AS/400 application. The problem I am experiencing is that the information will not paste or wrap correctly onto the lines (area) that I have selected. Only the first line will populate with the information copied from the Excel cell. If I am trying to do this task on my desktop PC it works fine, but I cannot get the same results when working on different desktops within the organization. Am I overlooking some settings? Please let me know if anyone has any suggestions or has experienced this problem in the past.

Answer Wiki

Thanks. We'll let you know when a new response is added.

A – First do a copy and paste to a empty text file in ‘Notepad’. This will tell us if all of the data is being caught by the copy step.
B – If the text file refects the SAME line breaks as the cell then it was not formatted with word wrap, BUT has line breaks at the end of each segment. This will cause some ‘400’ apps to stop pasting at the line break. I am presuming that ‘area’ you mention is in fact a single data field.
C – If in fact ther are multiple data fields (lines) then you need to parse the sell data with appropriate breaks.

Good luck.

Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • DaddyCOZ
    Your problem sounded interesting so I tried it and you are right. I am using Excel 2003 and it does not work. Of course, Excel is weird. Have you tried to put a carriage return into an Excel cell by pressing ENTER. It does not work; you have to press Alt ENTER. And dates are not really dates. And time is not really time. Excel is weird. As an example, the people at Apache call it hssf and use hssf for their Excel methods (horrible spread sheet format). I noticed that I get a control character on the front end when I copy a cell as opposed to copying text from a cell, but only when the cell is multiple lines. So, Excel must be doing something weird. I bet this will never work. Anybody got a way to make this work?
    0 pointsBadges:
  • JPLamontre
    Pasting is different from one desktop to the other : this says edit / options are not the same. there are thre different method to paste under Client Access PC program. Try them. Then feed back us what choice you have retained.
    0 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: