Connection failure using dotnet 1.0 and Oracle client 10g with Oracle 10g server

20 pts.
Microsoft Windows XP
Oracle 10g
Hi, I have application developed on dotnet 1.0 ( VS 2003) and Oracle 10g server. Client machine has windows XP ( sp2), Oracle client 10g,, mdac 2.6. ODBC connection is sucessful and using toad also i can connect client machine to server but using ditnet application ( ) id not connecting to database server. It gives an error of OCI.DLL. As an adminsitrator rights for folder Home_1 of read & ececute is given but the error is still exists. Can you please help me ? Is there any other patch for 10g client ? Thanks in advance.

Answer Wiki

Thanks. We'll let you know when a new response is added.

Has this worked before ? did you make any changes ?

Could you please post the exact error message ?
Also, could you please post the code you are using to connect to the database ?


Is working with only one machine. We have installed vs2003,, mdac 2.6 and oracle client 10g on fresh machine on windows XP ( sp2).

We have desktop application includes service which is running on Oracle server. Client desktop application is connected using app.config file, using remote connection with channel port number 8888 and singletonCall interface.

Please check the code,

using System;
using System.Collections;
using System.Data;<pre>
using System.Data.OracleClient;
using System.Configuration ;

public class Form_Login : System.Windows.Forms.Form
private OracleConnection objConnection = null;
private OracleCommand objCommand = null;

private void Form_Login_Load(object sender, System.EventArgs e)
objConnection = new OracleConnection();
objConnection.ConnectionString = “Password=amw001;User ID=amw001;Data Source=ORCL”

the exact error description :

<b>Error:Error in Form_Login_Load: The type initializer for “System.Data.OracleClient.OCI” threw an exception.</b>
We have also tried with simple application using the above code but same is also not working.

Kindly help.

Thanks in advance.</pre>

Discuss This Question: 2  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • carlosdl
    I'm not sure if you need this, but you could try upgrading mdac to 2.8 Download Data Access Components (MDAC) 2.8 here On the other hand, it seems that some Oracle client versions require that you give the 'Authenticated Users' security group read and execute permissons to the Oracle Home folder (and not just the bin subfolder). Follow these steps: 1. Log on to Windows as a user with Administrator privileges. 2. Launch Windows Explorer from the Start Menu and and navigate to the ORACLE_HOME folder 3. Right-click on the ORACLE_HOME folder and choose the "Properties" option from the drop down list. A "Properties" window should appear. 4. Click on the "Security" tab of the "Properties" window. NOTE: If you are running Windows XP and do not have a "Security" tab please do the following: (a) Open "Folder Options" in your Control Panel. (b) Choose the "View" tab. (c) Under "Advanced Settings" uncheck the option "Use simple file sharing (Recommended)". The "Security" tab should now be available. 5. Click on "Authenticated Users" item in the "Name" list (on Windows XP the "Name" list is called "Group or user names"). 6. Uncheck the "Read and Execute" box in the "Permissions" list under the "Allow" column (on Windows XP the "Permissions" list is called "Permissions for Authenticated Users"). 7. Re-check the "Read and Execute" box under the "Allow" column (this is the box you just unchecked). 8. Click the "Advanced" button and in the "Permission Entries" list make sure you see the "Authenticated Users" listed there with: Permission = Read & Execute Apply To = This folder, subfolders and files If this is NOT the case, edit that line and make sure the "Apply onto" drop-down box is set to "This folder, subfolders and files". This should already be set properly but it is important that you verify this. 9. Click the "Ok" button until you close out all of the security properties windows. The cursor may present the hour glass for a few seconds as it applies the permissions you just changed to all subfolders and files. 10. You must REBOOT YOUR COMPUTER to assure that these changes have taken effect. Failure to do this can prevent this procedure from working! 11. Re-execute the application and it should now work. NOTE: If the problem is still present after following steps 1-11 and rebooting your computer in step 10 you should perform the following two additional permissions settings at step 8 as described below. This may be necessary due to permissions that have been configured beyond the standard permissions setup when the OS was originally installed: 12. If the problem is still present, go back through these same 11 steps above, but when performing step 8additionally check both boxes entitled "Inherit from parent the permission entries that apply to child objects. Include these with entries explicitly defined here." AND "Replace permission entries on all child objects with entries shown here that apply to child objects" AND be sure to reboot in step 10.
    84,805 pointsBadges:
  • carlosdl
    If you have access to metalink, you could also apply patch This patch appear to be database-only but it can also be applied to the client software.
    84,805 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: