Cisco 7965 and remote SIP server not working

15 pts.
Cisco Phones
Hey guys, I have this very weird problem and I just can't fix it.. any ideas would be very appreciated! I have a Cisco 7965 ip phone here on my desk. I have a tftp + sip server running in a datacenter and it seems the phone fetches all the data from the tftp, but can't connect to the SIP server. Now here's the weird thing.. If I run the tftp + sip in the same local network with my cisco phone, everything works perfect! I can call outside and receive calls. As soon as the tftp or sip is outside (datacenter) I'm having this problem. To make it even more complicated, I've tried with iphone app Softphone, and then the external SIP does work! I've checked and double checked everything and it all looks okay.. so any suggestions what to do? (yes I have changed remote IP's + NAT settings) Thanks in advance!

Software/Hardware used:
Sipcat, Cisco 7965, Asterisk

Answer Wiki

Thanks. We'll let you know when a new response is added.

First things that come to mind are:

1) For the “external” TFTP/SIP providers, do you have the DHCP option 150 pointing to those IP addresses? I read that you changed remote IP/NAT, but I’m asking if the DHCP server your phone is connecting to is pointing it to the “remote” locations properly…

2) When you said it is working when you keep the TFTP/SIP internal, it works fine. What is running these services? Are you connecting you phones to a CME/CM solution? or are you running and asterisk/hybrid setup?

More info about your topology and services would make assisting you a bit easier

Discuss This Question: 3  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Chrisss
    What do you mean with option 150? DHCP for the phone is on the local network.. but the phone is currently DMZ but still doesn't work. The SIP server I'm using is SIPCAT ( which is based on Asterisk. The phone connects to the TFTP where it gets a config file ([max-address].cnf.xml ) with the SIP ip, it then (tries to) connect to the SIP server. This works perfect in local network, but not with the tftp/sipcat remote. I can see it connects to the TFTP because the phone labels change if I edit the xml config file. Thanks for your help Sixball!
    15 pointsBadges:
  • Sixball
    DHCP option 150 allows you to tell the phones where to go to get their IP info, their TFTP server and DNS server addresses. With the changes being made to the XML file showing up, it sounds like the TFTP server portion is correct... With the "local connection" registering the phones properly, and it not seeming to reach the "remote SIP server", can you ping that IP/URL from a local PC/Device? If so, I'd look at the routing from the phone, its VLAN and any ACL's that may be filtering your traffic...
    8,705 pointsBadges:
  • MaximumCanon
    Sorry to revive a dead post, but which pbx are you running? I am trying to get some 7965s to work on pbx in a flash with no luck. They hang at "Registering" Would you be able to post your xml files?
    10 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: