Cannot modify directories or files on my external drive

2115 pts.
Directory Assistance
external drive
Folder permissions
Windows 7 64-bit
So this is really stumping me. Starting this Monday I cannot Modify folders on my external. I can create them and open them but cannot save/rename or other modifies. I first noticed it because our remote IT company installed updates on Sunday and all the Microsoft update temp files were still on the drive and not deleted afterwards. When I started to play around with it I realized I could no longer modify anything on the external and would get an error saying "You require permission from administrators to make changes to this folder". This was odd to me because I thought I was the administrator. However I checked my user group and somehow I was placed in HelpLibraryUpdaters group- looked this up and has something to do with BITs and windows updates but was discontinued with Win7, which I am running. Anyways, switched my group back to Administrators. After that I got into Security and made sure my user had full access and ownership of drive and all subfolders and files. This worked to where I have the correct permissions and ownership for everything but still when I try to modify it said the original message but instead of administrators it now says I need permission from myself. It requires permission from Madison(our company domain) rbrown-which is me!!!!! To test if it was a profile issue I gave permissions and ownership to localadmin and logged on as that user and it give me the same error except now it was computerlocaladmin- the user I was logged in as. I have also checked local and domain group policies to see if anything was set to block modify access to externals and there is nothing. I also get error that Recycle Bin is corrupt on drive but cannot delete it cause I need permission from myself I think I have provided all the information I have even if some might not be relevant but feel free to ask for anything else, I am at a loss on what to do now. Please help.

Software/Hardware used:
windows 7; WD Elements 2 Tb External Drive

Answer Wiki

Thanks. We'll let you know when a new response is added.

You may have to go into the permission area of the ones that you are having problems with and first, break inheritance

/* Style Definitions */
{mso-style-name:”Table Normal”;
mso-padding-alt:0in 5.4pt 0in 5.4pt;
mso-fareast-font-family:”Times New Roman”;
mso-bidi-font-family:”Times New Roman”;

and then assume ownership gain of those areas.  If you do it at the TLF, it may take care of all of the subfolders.  We have this problem on occasion with customers who sometimes lose their rights to their own backup folder on the server.  It is a simple fix, but, depending on how much data you have, it could take awhile.  Good luck.

Discuss This Question: 1  Reply

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • RamseyB
    Thank you, so what I ended up doing was giving localadmin back the ownership of the drive.  Then I changed the computer name to new name and gave ownership back to domain account.  That somehow tricked it into working .  Do not ask me what it did but but I think there was just something corrupt in its relationship with the local accounts. 
    2,115 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: