Network connectivity problem with Windows XP SP2

Local area networks
Windows XP SP2
my network says I am connected but when I browse it will not show anything and it says Done. We have other unit which connected in the same network and it has no problem. If I try to restart my unit, at first I can browse but later on it stop and it will not change anything, but the connection says I am connected. I'd tried unplug the Lan cable from my unit to the switch and it connect again, but again later on it stop... I'd also tried dos command to ping a website and it reply continous but if I try to browse it wont. Can you help me with this problem?

Software/Hardware used:
Windows XP sp2

Answer Wiki

Thanks. We'll let you know when a new response is added.

I think we need more information about your connection when you are connected but network is not working.

Tell us the output for the following commands:

ifconfig /all
nslookup (this command will also show you your dns)

Also check your firewall status (look for antivirus firewall too). Better disable it for testing only.

Try to ping to your dns (showed by nslookup command)

If your adapter configuration is DHCP try the command “ifconfig /release” followed by the command “ifconfig /renew”, then try again your connection.

Hope it help you.

Discuss This Question: 7  Replies

There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Rakei
    One thing to consider..Install Service Pack 3 for your Windows XP and restart your P.C or unit. See if the problem still persist. If still didnt fix, you may want scan for any infections. hope this help.
    3,260 pointsBadges:
  • TomLiotta
    First thing I'd suggest is to get past SP2 and install SP3 at least (and possibly a number of other fixes). SP2 is somewhere over seven years old. It wasn't bad as Service Packs go, but a lot of networking changes have happened in the last seven years. Tom
    125,585 pointsBadges:
  • Jackulbond007
    @Mariodlq: Man thank you for replying. This are the output.... IP; Subnet: Default gateway: DNS: DNS: nslookup ***Can't find Server name for address Non-existing domain ***Can't find Server name for address Non-existing domain Default Server are not available Server Unknown Address BLablabla... I will try also to upgrade it to SP3.. Again Thanks man.
    30 pointsBadges:
  • Sixball
    I feel that the best palce to start is with your network topology.. Do you have the PCs plugged into a switch that in turn plugs into a cable / DSL modem? or do you have a router between your switch and your ISP device? The output you gave seesm to be from a DSL modem (pls correct me if i'm wrong), and if you're running a switch directly to it, they tend to only respond to one device (MAC address) regardless of whats cabled into them.. The symptoms you describe are very indicitive of a switch-to-ISP modem setup: one device works fine through the switch, while devices 2,3,4 etc do not....
    8,705 pointsBadges:
  • Jackulbond007
    hey everyone; I think this time its a virus or infection with my OS... have anyone encounter this kind of thing? For just a couple of minute it can browse and after it wont. It started to affect the other unit, I really cant find a way to solve this problem. the network has really no problem.
    30 pointsBadges:
  • Stevesz
    Ping your machine's IP address. If fail, 1. check your firewall settings on the local machine, then try again; 2. update your NIC driver & test; 3. if still fail, turn off firewall, turnoff A/V; still fail; 4. replace NIC. If OK, ping your router gateway) IP address. If fail, 1. check firewall settings; 2. if still fail, turn off firewall & A/V; 3. if still fail change port on switch to know good port test, if good, bad port, if fail, test other machine on original port for problem machine; 5. change cable or switch as applicable. If OK ping a known outside IP address. If fail, 1. check firewall on router to see if machine is allowed; If OK ping the known IP address by name. If this fails, check your nameserver addresses to ensure they are correct. If you are able to get all the way through by pinging, then put your machine in safe mode with networking, and try to reach the web with your browser again. You don't say which browser you are using, but the place to look is where a proxy server can be set. If you do not have a proxy server, then all the check boxes and addresses should be blank If you do have a proxy server, pretty rare in many cases today, ensure the settings are correct. Try again. If we are still failing, get Malwarebytes (use another machine if need be) and then install it in the safe mode you are in and update and run. Let it update, (if it can't, it will tell you) then run it to do a Quick Scan. This should find most malware on your machine.
    2,015 pointsBadges:
  • Chippy088
    I am guessing this is your home network. So what hardware are you using, and how old is it? The point Sixball made about the topology is a good one. Are you able to connect both PCs directly into the router to see if the problem corrects itself? Does the unit still have problems if you connect it to the good PCs socket on the switch? You don't say which browser(s) you are using on each PC. Are they up to date with all the latest updates? Does the browser have blocks on scripts running? If they are blocked, then you will get blank pages. You should get a message saying that the addins are needed to show the page. If you are unsure about infection, I would suggest firstly, trying to see what is running at start-up, using something like the autoruns program. You can temporarily suspend programs loading on start-up, until you find the one(s) causing the problem, which can then be removed by uninstalling it, or just selecting delete, to permanently stop it running.
    4,625 pointsBadges:

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.


Share this item with your network: