Black screen after installing GPU

15 pts.
Tags:
ASUS
GPU
So today I bought an Asus GTX 1050 2gb GPU and plugged it onto my motherboard (MSI military class 4 H81M-P33) and tried to boot it, but the monitor was just blank. Help me please.

Software/Hardware used:
Asus gtx 1050 2gb

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Discuss This Question: 2  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Subhendu Sen
    Probably there is something wrong/misconfiguration. Try to remove it and check if the monitor works properly. Have you check the Device manager? Try returning the original card back into the system to see if it then works. Also certified power supplies are strongly recommended.
    103,960 pointsBadges:
    report
  • aldrincruuz
    EDIT: Fixed it now. Thank you though. What i did was I installed ddu and uninstalled nvidia drivers then connected my GPU. And now its working, still thank you for answering.
    15 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: