RPGLE program is not picking up record

1230 pts.
Tags:
AS/400
RPGLE
I have SQL Table and Index. I am processing it in my RPGLE Program when Status = *blanks. In another session, I am updating record with Status = Blanks. My RPGLE Program is not picking this record. But my RPGLE picks newly inserted records. Please let me know the reason and how to read updated records also. I am using Keyword Read to read the files.


Software/Hardware used:
AS400
1

Answer Wiki

Thanks. We'll let you know when a new response is added.

If you are running both concurrently, when is the commit being done on the SQL table?  Or is this an I-Series table you may want to check the file parameter FRCRATIO. If writing just one record it may not happen immediately. That parameter controls the force write ratio and unless you specify *NONE it will wail till the file buffer is full or the program ends before the write takes place..

Discuss This Question:  

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: