TechStop


March 14, 2011  1:00 AM

MPLS Pseudo-Wire Basics – Part 4

Joshua Wood Joshua Wood Profile: Joshua Wood

Hello all, now that we have the design, CE and PE pieces outlined let’s go over the P or provider core routers. This is really straight forward because the core routers are essentially only receiving, re-tagging and sending the traffic out again. There is more to it than that of course but you don’t have the complexity of the PE routers that receive the traffic and tag it with MPLS data and then forward it on. The P routers are essentially only routing channels. Below are the configs for the P routers as shown in my original design (link below).

As a side note here that I will try to remember to reiterate when I do the final piece to this series, you can use a layer 2 switch in between the various devices as long as the MTU of the switches is high enough to allow for the oversized MPLS packets to pass through it. I recommend you use 1600 or greater for the MTU setting on the switches. This gives you some nice flexibility if you need to run your connection over a layer 2 switch to extend a cable length or connect two sites but don’t want to put another router in between.

P1#sh run
ip source-route
ip cef
!
interface Loopback0
description OSPF LOOPBACK
ip address 10.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description CONNECT TO P2
ip address 192.168.2.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface GigabitEthernet0/1
description CONNECT TO P3
ip address 192.168.4.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface GigabitEthernet0/2
description CONNECT TO PE1
ip address 172.16.1.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 101
router-id 10.1.1.1
log-adjacency-changes
network 10.1.1.1 0.0.0.0 area 0
network 172.16.1.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
!
P1#

P3#sh run
ip source-route
ip cef
!
interface Loopback0
description OSPF LOOPBACK
ip address 10.1.2.1 255.255.255.255
!
interface GigabitEthernet0/0
description CONNECT TO P1
ip address 192.168.2.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface GigabitEthernet0/1
description CONNECT TO P2
ip address 192.168.4.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface GigabitEthernet0/2
description CONNECT TO PE2
ip address 172.16.3.1 255.255.255.0
duplex auto
speed auto
mpls ip
!
router ospf 101
router-id 10.1.3.1
log-adjacency-changes
network 10.1.2.1 0.0.0.0 area 0
network 172.16.2.0 0.0.0.255 area 0
network 172.16.3.0 0.0.0.255 area 0
network 192.168.2.0 0.0.0.255 area 0
network 192.168.3.0 0.0.0.255 area 0
network 192.168.4.0 0.0.0.255 area 0
!
P3#

MPLS Pseudo-wire Basics Part 1: http://itknowledgeexchange.techtarget.com/techstop/mpls-pseudo-wire-basics/

Until next time,
TechStop

March 11, 2011  1:00 AM

MPLS Pseudo-Wire Basics – Part 3

Joshua Wood Joshua Wood Profile: Joshua Wood

Welcome back, after the previous two posts we have the design and the client side devices. These are pretty straightforward. The client devices are obviously out of the loop when it comes to participating in the layer 2 tunneling of traffic across the providers network. Let’s take a look at the piece that connects to the provider network. Below are the configs for the two PE routers. Again, I have tried to clean/reduce them as much as possible to only show the relevant pieces but there might be some artifacts left over.

Basically what is happening here is that on the interface GigabitEthernet0/1.250 we are taking in the information that the client gives to us and encapsulating inside of an MPLS structure in order to send it across the network. This is done mostly using the three commands “xconnect 10.2.3.1 200 pw-class 200” and “pseudowire-class 200” and “encapsulation mpls”.

The next phase of this is to send the MPLS encapsulated layer 2 traffic across the “P” or provider core routers. Those routers we will look in the next post. After that we will have a recap of everything in order to make sure that the little points are clear enough for everyone. If there are any questions or comments please feel free to fire away at any point.

PE1#sh run
ip cef
!
pseudowire-class 200
encapsulation mpls
!
interface Loopback0
ip address 10.2.1.1 255.255.255.255
!
interface GigabitEthernet0/0
description CONNECT TO P1
ip address 172.16.1.2 255.255.255.0
duplex auto
speed auto
mpls ip
!
interface GigabitEthernet0/1
description CONNECT TO CLIENT 200
no ip address
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1.250
description CONNECT TO CLIENT 200
encapsulation dot1Q 200
xconnect 10.2.3.1 200 pw-class 200
!
router ospf 101
router-id 10.2.1.1
log-adjacency-changes
network 10.2.1.1 0.0.0.0 area 0
network 172.16.1.0 0.0.0.255 area 0
network 172.16.3.0 0.0.0.255 area 0
!
router bgp 65535
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.2.2.1 remote-as 65535
neighbor 10.2.2.1 update-source Loopback0
neighbor 10.2.3.1 remote-as 65535
neighbor 10.2.3.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 10.2.2.1 activate
neighbor 10.2.3.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
neighbor 10.2.3.1 activate
neighbor 10.2.3.1 send-community extended
exit-address-family
!
ip forward-protocol nd
!
PE1#

PE3#sh run
pseudowire-class 200
encapsulation mpls
!
interface Loopback0
ip address 10.2.3.1 255.255.255.255
!
interface GigabitEthernet0/0
description CONNECT TO P3
ip address 172.16.3.2 255.255.255.0
duplex auto
speed 100
mpls ip
!
interface GigabitEthernet0/1.250
description CONNECT TO CLIENT 200
encapsulation dot1Q 200
xconnect 10.2.1.1 200 pw-class 200
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
!
router ospf 101
router-id 10.2.3.1
log-adjacency-changes
network 10.2.3.1 0.0.0.0 area 0
network 172.16.3.0 0.0.0.255 area 0
!
router bgp 65535
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 10.2.1.1 remote-as 65535
neighbor 10.2.1.1 update-source Loopback0
neighbor 10.2.2.1 remote-as 65535
neighbor 10.2.2.1 update-source Loopback0
!
address-family ipv4
no synchronization
neighbor 10.2.1.1 activate
neighbor 10.2.2.1 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 10.2.1.1 activate
neighbor 10.2.1.1 send-community extended
neighbor 10.2.2.1 activate
neighbor 10.2.2.1 send-community extended
exit-address-family
!
ip forward-protocol nd
!
PE3#

MPLS Pseudo-Wire Basics – Part 1: http://itknowledgeexchange.techtarget.com/techstop/mpls-pseudo-wi…2%80%93-part-2mpls-pseudo-wire-basics-%e2%80%93-part-2/

Until next time,
TechStop


March 9, 2011  1:00 AM

MPLS Pseudo-Wire Basics – Part 2

Joshua Wood Joshua Wood Profile: Joshua Wood

Hello, now that we have the initial design laid out and now that we have some of the basic terminology outlined let’s start laying out the configs. For this lab setup I am using all Cisco 2911 routers with the Data feature set running IOS 15.1. That is a long way of saying that I am using MPLS capable routers. For an overview of the design see part 1 of this series of posts; link is at the bottom.

Now to the configs, I have put the two configs for the CE devices here. There isn’t anything special here with these configs. These devices are the customer devices that would connect to the ISP or the providers network. These configs are connecting to the provider by wrapping the traffic in a 802.1Q trunk. However, you don’t need a 802.1Q trunk in order to send layer 2 traffic through this infrastructure. If both ends of the connection aren’t tagging then it will work just fine. Quick note, i have stripped the configs down to the basics for ease of viewing.

CE1#sh run

ip cef
!
interface Loopback0
ip address 10.100.100.1 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.250
description VLAN 250 – PW CCT
encapsulation dot1Q 200
ip address 192.168.2.1 255.255.255.0
!
router eigrp 101
network 10.100.100.1 0.0.0.0
network 192.168.2.0
!
CE1#

CE3#sh run
interface Loopback0
ip address 10.100.100.2 255.255.255.255
!
interface GigabitEthernet0/0
description VLAN 250 – PW CCT
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.250
description VLAN 250 – PW CCT
encapsulation dot1Q 200
ip address 192.168.2.3 255.255.255.0
!
router eigrp 101
network 10.100.100.2 0.0.0.0
network 192.168.2.0
!
CE3#

MPLS Pseudo-Wire Basics – Part 1: http://itknowledgeexchange.techtarget.com/techstop/mpls-pseudo-wire-basics/

Until next time,
TechStop


March 7, 2011  1:00 AM

MPLS Pseudo-Wire Basics – Part 1

Joshua Wood Joshua Wood Profile: Joshua Wood

Hello, I work for an ISP. As one of the tasks that I have deploying tech that isn`t necessarily new but is new to my company is part of my job. One of the exciting techs that I get to test and deploy is called MPLS or Multi-Protocol Label Switching. And it is awesome. When I was looking at deploying it for the company that I work for one of the frustrations that I had was getting a very basic pseudo-wire configuration off of the Internet. It seemed like I was mining for a needle in a haystack that that seemed like it should have been made of needles. It was bizarre.

Over the next few posts I am going to attempt to show you a very basic pseudo-wire MPLS configuration that I used in my labs. Before I do that though, let me outline what a pseudo-wire is. Pseudo-wire in the context of MPLS is typically a layer 2 tunnel between two endpoints that runs over a layer 3 network and uses the routing protocols of that network. Now of course it gets more complicated than that but in a very basic sense it is like taking a cable from one switch and running it virtually over a part of the internet to a switch in another building or city. Pretty cool stuff!!!

Now before I go too far, here is the design and layout that I am going to use. The configs and explanations will come later. This is a basic setup where the CE devices are the customer routers or switches and the P devices are anything the provider or core network. CE could also be branch devices in a large network.

Until next time,
TechStop


March 4, 2011  9:12 PM

Hello World … again

Joshua Wood Joshua Wood Profile: Joshua Wood

Hello world … again, I have been out of the blogging world for a while now and have decided it was time for me to get back into it. There are a number of topics that I have searched for on the InterWebs and have been frustrated that there wasn’t information or at least the information that I was looking for. Over the many months to come I will try to get those tidbits of information that I did eventually find out on there in a way that we can all use, maybe even for myself.

Some of the topics that I will be covering are:
– Basic BGP multi-homed setup
– Virtualization tools
– SAN storage options
– MPLS basic setup for pseudo-wire
– And much more.

I look forward to hearing your comments along the way.

TechStop (A.K.A. — Josh)


August 31, 2008  9:29 PM

Linux E-Mail Client

Joshua Wood Joshua Wood Profile: Joshua Wood

List of email clients for Linux.

http://www.ubuntugeek.com/list-of-email-clients-available-in-ubuntu-linux.html


August 31, 2008  9:26 PM

OpenFire 3.6.0 Released

Joshua Wood Joshua Wood Profile: Joshua Wood

OpenFire is a free jabber server with a slick web interface that integrates with the Asterisk phone system.

http://www.igniterealtime.org/community/blogs/ignite/2008/08/27/openfire-360-has-been-released


August 30, 2008  9:26 PM

New Procurve Gigabit Switch

Joshua Wood Joshua Wood Profile: Joshua Wood

The HP Procurve 2510 offers performance and management at a low cost.

http://www.hp.com/rnd/products/switches/ProCurve_Switch_2510_Series/overview.htm


August 30, 2008  9:23 PM

Free iSCSI Server

Joshua Wood Joshua Wood Profile: Joshua Wood

OpenFiler is a fast, flexible and free iSCSI server. It runs quickly and efficiently with a Linux core.

http://www.openfiler.com/


August 28, 2008  1:21 PM

Cisco to Target Exchange

Joshua Wood Joshua Wood Profile: Joshua Wood

Based on a few articles and blogs it looks like Cisco is going to start tredding into Microsoft’s territory a bit. Granted Microsoft Exchange is a well established product and it is unlikely that anyone is going to displace it easily but Cisco has a habit of taking over industries that it sees as available (i.e. VoIP).

As much as Cisco and Microsoft usually play in different sand boxes Cisco seems to think that Microsoft’s sand box needs to be a little bit smaller. It likely wont affect the market for a while but it should be interesting to watch this unfold.

Links
Information Week – Cisco Buys PostPath, Targets MS Exchange
http://www.informationweek.com/blog/main/archives/2008/08/cisco_buys_post.html

Gigaom – Why Cisco Bought Mail Startup PostPath for $215M
http://gigaom.com/2008/08/27/why-cisco-bought-mail-startup-postpath-for-215-million/


Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: