TechStop

Mar 9 2011   1:00AM GMT

MPLS Pseudo-Wire Basics – Part 2



Posted by: Joshua Wood
Tags:
Cisco
MPLS

Hello, now that we have the initial design laid out and now that we have some of the basic terminology outlined let’s start laying out the configs. For this lab setup I am using all Cisco 2911 routers with the Data feature set running IOS 15.1. That is a long way of saying that I am using MPLS capable routers. For an overview of the design see part 1 of this series of posts; link is at the bottom.

Now to the configs, I have put the two configs for the CE devices here. There isn’t anything special here with these configs. These devices are the customer devices that would connect to the ISP or the providers network. These configs are connecting to the provider by wrapping the traffic in a 802.1Q trunk. However, you don’t need a 802.1Q trunk in order to send layer 2 traffic through this infrastructure. If both ends of the connection aren’t tagging then it will work just fine. Quick note, i have stripped the configs down to the basics for ease of viewing.

CE1#sh run

ip cef
!
interface Loopback0
ip address 10.100.100.1 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.250
description VLAN 250 – PW CCT
encapsulation dot1Q 200
ip address 192.168.2.1 255.255.255.0
!
router eigrp 101
network 10.100.100.1 0.0.0.0
network 192.168.2.0
!
CE1#

CE3#sh run
interface Loopback0
ip address 10.100.100.2 255.255.255.255
!
interface GigabitEthernet0/0
description VLAN 250 – PW CCT
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.250
description VLAN 250 – PW CCT
encapsulation dot1Q 200
ip address 192.168.2.3 255.255.255.0
!
router eigrp 101
network 10.100.100.2 0.0.0.0
network 192.168.2.0
!
CE3#

MPLS Pseudo-Wire Basics – Part 1: http://itknowledgeexchange.techtarget.com/techstop/mpls-pseudo-wire-basics/

Until next time,
TechStop

 Comment on this Post

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when other members comment.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: