Network technologies and trends


September 8, 2009  9:45 AM

Remote Telnet useful tips!

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

We all work remotely with Cisco routers and Switches, we often do login to do some configuration changes in the Cisco routers and Switches. What if we configured wrongly in the live Cisco routers and Switches which are located in the remote sites, we don’t enjoy the liberty of resetting the devices unless we have control over the power distribution.

 

In this scenario the “reload” command proves to be very handy and useful. Just before making any changes to the configuration we can use the “reload” command as demonstrated below

 

ITKE-Cisco#reload in ?

Delay before reload (mmm or hhh:mm)

 

ITKE-Cisco#reload in 10

 

System configuration has been modified. Save? [yes/no]: no

Building configuration…

[OK]

Reload scheduled in 10 minutes by yasir on vty0 (10.0.0.5)

Proceed with reload? [confirm]

ITKE-Cisco#

ITKE-Cisco#

 

 

***

*** — SHUTDOWN in 0:05:00 —

***

 

The above demonstrated command will reload the device in 10 minutes. After applying the “reload” command we can proceed with the configuration changes. If things go wrong and we lost connectivity

to the device, then try back after 10 minutes as the device will get reloaded with the original startup-configuration which can helps us to restore the connectivity to the device.

 

Once we are sure about the new configuration and its working properly without any hassles there is always a way  “reload cancel” command is there to cancel the reload.

 

ITKE-Cisco#reload cancel

 

I find this command to be very handy and useful especially when we have to telnet or SSH to remote Cisco router or a Switch.

September 5, 2009  8:32 PM

Review for Interconnecting Data Centers Using VPLS

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

Interconnecting Data Centers Using VPLS is a book which aims at providing solutions that provide a high speed, low latency network and spanning tree protocol (STP) isolation between data centers based on Virtual Private LAN Service (VPLS).

Pic Courtesy: Cisco Press

The book makes interesting reading, especially as it covers in detail about the architecture design and configuration required to interconnect data centers as well as case studies to interconnect Data Centers.  This book is targeted to Systems professionals and System engineers who are into designing solutions for interconnecting data centers which ensures high availability Layer 2 connectivity and STP isolation.

The authors Nash Darukhanawalla and Patrice Bellagamba started the book with explaining the need for high availability of the Data Centers, explaining the concept of the high availability clusters, introduction to Virtual Private LAN Service (VPLS), MPLS traffic engineering.

The authors’ present different flavors of data center interconnect solution using different combination of Spanning Tree modes, VLAN mapping as well other criteria’s along with complete configuration required at the  aggregation switches and provider edge routers.

The book is divided into 13 chapters, and it also deals with issues related to layer 2 bridging domains and provides guidance to extend VLANs using Virtual Private LAN Service (VPLS). This book contains lot of reference network diagrams which can help the readers to understand the presented solutions in normal mode as well as in failover mode.

I found this book extremely readable and enjoyable and I would recommend this book to the folks who are interested in knowing more about the Virtual Private LAN Service (VPLS). The book comes with lot of useful information which will definitely help the readers to get familiar with the Virtual Private LAN Service (VPLS) concepts and configuration steps required for interconnecting data centers.


September 5, 2009  8:07 AM

Review for CCNP BCMSN Official Exam Certification Guide (4th Edition)

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

Hi folks, as I received a CCNP Official Certification Library, fifth edition thanks to Cisco Press (Jamie) for the great support lending on me all the time. To brief about the CCNP Official Certification Library, fifth edition is a comprehensive package for the four Cisco CCNP exams BCMSN, BSCI, ISCW and ONT. Starting from this post I will try my best review all the four Certification books comes with the CCNP Official Certification Library, fifth edition thanks. To start with I will go with the CCNP BCMSN Official Exam Certification Guide, fourth edition.

The CCNP BCMSN Official Exam Certification Guide, fourth edition is a true guide for preparing for the Cisco BCMSN (642-812) exam. The author David Hucaby did a wonderful job by the explaining the material in short concise way that facilitates easy learning.

The CCNP BCMSN Official Exam Certification Guide, fourth edition is divided into six parts , each part is well written and  more over its easy to understand. The most liked chapter for me is the Router, Supervisor and Power redundancy. Thanks to David Hucaby, I was able to migrate our network from HSRP to GBLP succefully. He explained the concept very well like I said it’s really easy to understand.

The CCNP BCMSN Official Exam Certification Guide, fourth edition does have the Scenarios for final preparations  There are nine scenarios covering wide range of concepts and are helpful not only from the exam point of view but also it can be used to troubleshoot the problems in real networks faced by some folks.

One more amazing thing I liked in the CCNP BCMSN Official Exam Certification Guide, fourth edition is the practice exams which are handful for the folks who has little exposure to real world networks, but it’s always recommend to have some hands on experience with Switches configuration and analysis.

Overall an excellent guide which can leads you to taste the success of passing Cisco BCMSN (642-812) exam. I would rate this guide 4.5 out of 5.


August 29, 2009  7:13 AM

Building a Green Data Center? Then Join hands with Douglas Alger on September 24, 2009

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Building a Green Data Center?  Then Join hands with Douglas Alger on September 24, 2009

Safari Online is conducting a Webcast Series on the topic “Grow a Green Data Center” with Douglas Alger the author of the book “Grow a Green Data Center” on September 24, 2009. 

 Register now and by attending the Webcast you are eligible to win free 45 DAYS OF COMPLIMENTARY ACCESS to Grow a Greener Data Center. Even The first 10 people to register for the webcast will receive a FREE AUTOGRAPHED COPY of Grow a Greener Data Center. You must attend in order to win.

The Event information is as follows

Date and time:

Thursday, September 24, 2009 9:00 am
Pacific Daylight Time (San Francisco, GMT-07:00)
Change time zone

 

Thursday, September 24, 2009 12:00 pm
Eastern Daylight Time (New York, GMT-04:00)

Program:

Safari Books Online Webcast Series

Duration:

1 hour 15 minutes

Description:

Data centers have historically had a huge environmental impact — consuming massive amounts of power, emitting pollutants, and discarding huge amounts of machine waste. Companies are increasingly objecting to the financial and public relations costs they are paying for environmentally insensitive data centers. Fortunately, it’s now both possible and cost-effective to run a “green data center.” In this one hour webcast, author Doug Alger makes the business case for greening data centers, and presents technologies, design strategies and operational approaches that can help any company improve the energy efficiency and “eco-friendliness” of their IT facilities. He walks step-by-step through “greening” physical construction, power, cooling, and servers; then covers equipment consolidation, virtualization, and much more.

 

 


August 26, 2009  7:46 AM

Pre-Order the Cisco Product Quick Reference Guide

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

Coming September 14th 2009 you can pre-order the September 2009 edition of the Cisco Product Quick Reference Guide. This guide presents an overview of Cisco products, services and solutions for every part of your business. It meets information needs for companies of all sizes.

The portable and easy-to-use reference tool includes brief product overviews, important features, technical specifications, part numbers, and ordering information for many of Cisco products and services. It’s designed to help our partners, resellers, distributors, and sales account teams quickly learn about and sell Cisco products, services and solutions that are right for their customers. It’s also ideal for end users, networking professionals, Cisco Networking Academy members, and those studying for Cisco certification who need a broad, high- level overview.

You can pre order just by visiting the Cisco Product Quick Reference Guide website at www.cisco.com/go/guide and click on the Ordering link.


August 22, 2009  8:46 AM

Configuring Multiple SSIDs in Cisco 1250 Access Points Series 6

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

In this post I will just post the snap shots for SSIDS ADMIN and GUEST, where you can see the SSIDS are connected, they got an IP address and they can ping the default gateway as well. It’s just to confirm  connectivity.

ADMIN SSID Connectivity

The PC is getting an IP from the DHCP Server for the SSID ADMIN  and VLAN 101

The PC can ping the default gateway

GUEST SSID Connectivity

The PC is getting an IP from the DHCP Server for the SSID GUEST and VLAN 102

 The PC can ping the default gateway

So with this I will conclude this series. If any body have any comments please do comment.


August 18, 2009  7:47 AM

Configuring Multiple SSIDs in Cisco 1250 Access Points Series 5

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

Dear all lets proceed further with the configuration of the Cisco Catalyst 3560 Switch

 

Configure the Cisco Catalyst 3560 Switch.

 

In this step we will configure the Cisco Catalyst 3560 Switch port which is connected to the Cisco Aironet 1250 Series Access Point to the wired network. We will configure the Cisco Catalyst 3560 Switch port, which is connected to the Cisco Aironet 1250 Series Access Point as trunk port because this port will carries traffic for all the VLANs on the wired network. In our case the VLANs are VLAN 101, 102 and the native VLAN 100.

When you configure the Cisco Catalyst 3560, which connects to the Cisco Aironet 1250 Series Access Point ,ensure that the native VLANs that you configure match the native VLAN on the Cisco Aironet 1250 Series Access Point. Otherwise, frames are dropped. In order to configure the trunk port on the Cisco Catalyst 3560 Switch, use the following commands from the CLI on the Cisco Catalyst 3560 switch:

Note: In our scenario the Cisco Aironet 1250 Series Access Point is connected to a Cisco Catalyst 3560 Switch to the port number Giga Ethernet 0/20

ITKE-Cisco(config)#interface interface gigabitEthernet 0/20

ITKE-Cisco(config-if)# switchport mode trunk

ITKE-Cisco(config-if)#switchport trunk encapsulation dot1q

ITKE-Cisco(config-if)#switchport trunk native vlan 100

ITKE-Cisco(config-if)#switchport trunk allowed vlan 101,102

ITKE-Cisco(config-if)#switchport nonegotiate

ITKE-Cisco(config-if)#

 

(The above commands configures the Giga Ethernet port 0/20  as trunk port, with a dot1q encapsulation , with VLAN 100 as a native trunk VLAN ).

 

Note: Cisco IOS Software-based Aironet wireless equipment does not support Dynamic Trunking Protocol (DTP). Therefore, the Cisco Catalyst 3560 must not try to negotiate DTP.

With this configuration we have successfully completed the configuration of multiple SSIDs in the Cisco Aironet 1250 Series Access Point . In the coming post I will post the snap shots for the connection established to SSIDS ADMIN and GUEST. Basically we will test the connectivity with the ping command.

 

 


August 17, 2009  5:40 AM

Configuring Multiple SSIDs in Cisco 1250 Access Points Series 4

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

In the previous post we looked at configuration of the VLANs and SSIDS in a Cisco Aironet 1250 Series Access Point.  The final configuration in the Cisco Aironet 1250 Series Access Point should be as follows, I am just posting the complete running configuration from the Cisco Aironet 1250 Series Access Point

 

 

ITKE-AP-01# show running-config

Building configuration…

 

Current configuration : 2693 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname ITKE-AP-01

!

enable secret 5 $1$d1hx$IvRMqYGHs0JXjIgy8/.Ms0

!

no aaa new-model

!

!

!

dot11 ssid ADMIN

   vlan 101

   authentication open

!

dot11 ssid GUEST

   vlan 102

   authentication open

   guest-mode

   mbssid guest-mode

!

power inline negotiation prestandard source

!

!

username Cisco password 7 00271A150754

!

bridge irb

!

!

interface Dot11Radio0

 no ip address

 no ip route-cache

 !

 ssid ADMIN

 !

 ssid GUEST

 !

 mbssid

 station-role root

!

interface Dot11Radio0.100

 no ip route-cache

!

interface Dot11Radio0.101

 encapsulation dot1Q 101

 no ip route-cache

 bridge-group 101

 bridge-group 101 subscriber-loop-control

 bridge-group 101 block-unknown-source

 no bridge-group 101 source-learning

 no bridge-group 101 unicast-flooding

 bridge-group 101 spanning-disabled

!

interface Dot11Radio0.102

 encapsulation dot1Q 102

 no ip route-cache

 bridge-group 102

 bridge-group 102 subscriber-loop-control

 bridge-group 102 block-unknown-source

 no bridge-group 102 source-learning

 no bridge-group 102 unicast-flooding

 bridge-group 102 spanning-disabled

!

interface Dot11Radio0.100

 encapsulation dot1Q 100 native

 no ip route-cache

 bridge-group 1

 bridge-group 1 subscriber-loop-control

 bridge-group 1 block-unknown-source

 no bridge-group 1 source-learning

 no bridge-group 1 unicast-flooding

 bridge-group 1 spanning-disabled

!

interface Dot11Radio1

 no ip address

 no ip route-cache

 !

 ssid ADMIN

 !

 dfs band 3 block

 channel dfs

 station-role root

 bridge-group 1

 bridge-group 1 subscriber-loop-control

 bridge-group 1 block-unknown-source

 no bridge-group 1 source-learning

 no bridge-group 1 unicast-flooding

 bridge-group 1 spanning-disabled

!

interface GigabitEthernet0

 no ip address

 no ip route-cache

 duplex auto

 speed auto

!

interface GigabitEthernet0.101

 encapsulation dot1Q 101

 no ip route-cache

 bridge-group 101

 no bridge-group 101 source-learning

 bridge-group 101 spanning-disabled

!

interface GigabitEthernet0.102

 encapsulation dot1Q 102

 no ip route-cache

 bridge-group 102

 no bridge-group 102 source-learning

 bridge-group 102 spanning-disabled

!

interface GigabitEthernet0.100

 encapsulation dot1Q 100 native

 no ip route-cache

 bridge-group 1

 no bridge-group 1 source-learning

 bridge-group 1 spanning-disabled

!

interface BVI1

 ip address 10.0.0.99 255.255.254.0

 no ip route-cache

!

ip default-gateway 10.0.0.1

ip http server

no ip http secure-server

bridge 1 route ip

!

!

!

line con 0

line vty 0 4

 login local

!

end

 

ITKE-AP-01#

 

In my next post as promised I will post the configuraton for the Cisco Catalyst 3560 Switch.


August 16, 2009  4:53 AM

Configuring Multiple SSIDs in Cisco 1250 Access Points Series 3

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

In today’s entry we will focus on configuration of VLANs and SSIDs in a Cisco Aironet 1250 Series Access Point. The procedure is as follows.

 

Configure

 

In this section, you will see the configuration steps required to complete the above mentioned scenario.

 

1st Step: Configure the Native VLAN on the Cisco Aironet 1250 Series Access Point

The Native VLAN is a VLAN to which the Cisco Aironet 1250 Series Access Point and the Cisco Catalyst 3560 Switch are connected. Native VLAN of the Cisco Aironet 1250 Series Access Point is usually different from the other VLANS configured in the Cisco Aironet 1250 Series Access Point (In our case VLAN 101 and VLAN 102). The IP address used for the management of the Cisco Aironet 1250 Series Access Point is assigned to its BVI Interface and the IP address assigned is in the native VLAN. (In our case VLAN 100). . The traffic, for example, management traffic, sent to and by the Point itself assumes the native VLAN (VLAN 100), and it is untagged. All untagged traffic that is received on an IEEE 802.1Q (dot1q) trunk port is forwarded with the native VLAN (VLAN 100) that is configured for the port. If a packet has a VLAN ID that is the same as the native VLAN ID of the sending port, the Cisco Catalyst 3560 Switch sends the packet without a tag. Otherwise, the switch sends the packet with a tag.

In order to configure a native VLAN on a Cisco Aironet 1250 Series Access Point, issue the following commands in the global configuration mode on the Cisco Aironet 1250 Series Access Point

 

ITKE-AP-01(config)#interface gigabitEthernet 0.100

ITKE-AP-01(config-subif)# encapsulation dot1Q 100 native

ITKE-AP-01(config-subif)#exit

 

(The above commands will configure the encapsulation as dot1q and assign VLAN 100 as the native VLAN on the Giga Ethernet interface.)

 

ITKE-AP-01(config)#interface dot11radio 0.100

ITKE-AP-01(config-subif)# encapsulation dot1Q 100 native

ITKE-AP-01(config-subif)#exit

 

(The above commands will configure the encapsulation as dot1q and assign VLAN 100 as the native VLAN on the radio interface.)

 

 

2nd Step: Configure the SSIDs on the Cisco Aironet 1250 Series Access Point

In this step we will configure two VLANs (VLAN 101 & VLAN 102) one for the ITKE administration department and other for the guest users only with an internet access.  The SSIDs are also need to be associated with specific VLANS as shown below.

 

·         VLAN 101 for the ITKE administration department and uses the SSID ADMIN.

·         VLAN 102 for the guest users and uses the SSID GUEST.

 

In order to configure a VLAN101 and 102 on a Cisco Aironet 1250 Series Access Point, issue the following commands in the global configuration mode on the Cisco Aironet 1250 Series Access Point

 

ITKE-AP-01(config)#dot11 ssid ADMIN

ITKE-AP-01(config-ssid)#authentication open

ITKE-AP-01(config-ssid)#vlan 101

 (The above commands will create an ssid ADMIN, assigned to VLAN 101 and with an open authentication.)

 

ITKE-AP-01(config)#dot11 ssid GUEST

ITKE-AP-01(config-ssid)#authentication open

ITKE-AP-01(config-ssid)#vlan 102

(The above commands will create an ssid GUEST, assigned to VLAN 102 and with an open authentication).

 

ITKE-AP-01(config)#interface gigabitEthernet 0.101

ITKE-AP-01(config-subif)#encapsulation dot1Q 101

ITKE-AP-01(config-subif)#bridge-group 101

ITKE-AP-01(config-subif)#exit

ITKE-AP-01(config)#

(The above commands will set the encapsulation dot1q for VLAN 101 and assigns the sub interface to bridge group 101 to the giga Ethernet).

 

ITKE-AP-01(config)#interface dot11Radio 0.101

ITKE-AP-01(config-subif)#encapsulation dot1Q 101

ITKE-AP-01(config-subif)#bridge-group 101

ITKE-AP-01(config-subif)#exit

ITKE-AP-01(config)#

 

(The above commands will set the encapsulation dot1q for VLAN 101 and assigns the sub interface to bridge group 101 to the sub interface on the radio interface).

 

 

ITKE-AP-01(config)#interface gigabitEthernet 0.102

ITKE-AP-01(config-subif)#encapsulation dot1Q 102

ITKE-AP-01(config-subif)#bridge-group 102

ITKE-AP-01(config-subif)#exit

ITKE-AP-01(config)#

(The above commands will set the encapsulation dot1q for VLAN 102 and assigns the sub interface to bridge group 102 to the giga Ethernet).

 

ITKE-AP-01(config)#interface dot11Radio 0.102

ITKE-AP-01(config-subif)#encapsulation dot1Q 102

ITKE-AP-01(config-subif)#bridge-group 102

ITKE-AP-01(config-subif)#exit

ITKE-AP-01(config)#

(The above commands will set the encapsulation dot1q for VLAN 101 and assigns the sub interface to bridge group 101 to the sub interface on the radio interface).

 

3rd Step: Assign the multiple SSIDs to the radio interface on the Cisco Aironet 1250 Series Access Point

 

ITKE-AP-01(config)#interface dot11Radio 0

ITKE-AP-01(config-if)#ssid ADMIN

ITKE-AP-01(config-if)#ssid GUEST

ITKE-AP-01(config-if)#mbssid

(The above commands assigns the multiple SSIDs ADMIN and GUEST  to the radio interface dot11radio 0 ).

 

Note: The SSIDs ADMIN and GUEST are configured for open authentication, For information on how to configure different authentication types on the Cisco Aironet 1250 Series Access Point , refer the Cisco document “Configuring Authentication Types”.

In next post we will look at the configuration for the Cisco 3560 Switch .


August 15, 2009  5:41 AM

With Cisco’s Telepresence you can win 3000 $!

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

 

Why do want Cisco TelePresence ?  Answer this question in a video format, and submit your entries before 8th of September 2009 and win 3000 $.

 

 Amazing right!  Cisco TelePresence recently launched a video contest “Why I Want Cisco TelePresence”

The video contest is designed to entice individuals from around the world to submit their ideas about why or how they would like to use Cisco TelePresence in their work lives – how they might connect to co-workers or peers in other locations; the benefits they would uniquely reap; why they would be the ideal person to use a Cisco TelePresence system. Winners in two categories, Productivity and Shaping the Future, have a chance to win $3,000 each.

[kml_flashembed movie=”http://www.youtube.com/v/FMqB88AsqDM” width=”425″ height=”350″ wmode=”transparent” /] 

 

The Contest is open to individuals who: (1) are at least 21 years of age as of the Contest start date and (2) work or have worked within a professional organization that uses technology. Submission period ends at September 8, 2009 at 11:59 p.m.


Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: