Network technologies and trends


May 28, 2011  8:52 AM

Mango is the code-name for the Windows Phone 7 update

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Starting September 2011 all Windows Phone 7 customers can avail more than 500 new features which were revealed by Microsoft at the launch event held at the Burj Al Arab in Dubai. All new Windows Phone 7 will also have the Mango update.

Gustavo Fuchs, director Mobility, Microsoft Middle East and Africa says the Windows Phone operating system has so far received great feedback from customers in the seven months since it has been released.

“Ninety percent of people are extremely pleased with the product, 93% of people recommend the product to colleagues and family and the return rates on the smartphones are very, very low, which we know is not a common practice in the market,” he said.

One of the promising feature I liked in this update is users can group together contacts from multiple sources, such as Facebook and Gmail and a user can text all these contacts at the same time.

The phones allow users to switch between text, Windows Live Messenger and Facebook chat in the same conversation. Photo tagging and face-recognition is also enabled on the Mango update, allowing users to communicate on the go.

The new update allows users to multi-task and the enterprise clients can enjoy corporate messenger. Currently Windows Phone application market has over 17,000. Let’s see how Microsoft fights the smartphone race. Currently Android is heading for a major breakthrough as day by day its market share is increasing.

May 28, 2011  6:01 AM

Cisco has become the #3 player worldwide in x86 blade server factory revenue

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Almost two years back Cisco Systems delivered a new system that unite compute, network, storage access and virtualization into one cohesive system. Yeah Cisco Systems created history by entering into the blade server market.

I thought Blade servers that Cisco Systems, they must be joking; honestly I thought it was a crazy move from Cisco Systems. But they outperformed many of their competitors. In just two years, sales of the Unified Computing System are outpacing market growth for x86 blades, and Cisco has become the #3 player worldwide in x86 blade server factory revenue

Blades are forecast to be the fastest growing segment of the x86 server market and market data illustrates the impact of UCS innovation: businesses worldwide shifted over 10% of the x86 blade market to UCS, and in the U.S. nearly 20%. Cisco’s rapid growth underscores their leadership in the industry transition to fabric computing and converged infrastructure. Cisco reported 5,400 UCS customers and an annualized order run rate of $900M for UCS product orders.

According to IDC press release HP maintained the number 1 spot in the server blade market in 1Q11 with 50.0% revenue share, while IBM finished with 20.2% revenue share. Cisco and Dell rounded out the top 4 with 9.4% and 8.4% factory revenue share, respectively.


May 28, 2011  5:12 AM

Cisco Catalyst 6500 Series Switches supports next-generation medianet, Cisco EnergyWise, TrustSec, and Borderless Mobility.

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

The newly released Cisco IOS Software Release 12.2(33) SXI4 brings groundbreaking Borderless Networks innovations to Cisco Catalyst 6500 Series Switches. With more than 50 improvements the Cisco IOS Software Release 12.2(33)SXI4 helps deliver next-generation medianet, Cisco EnergyWise, TrustSec, and Borderless Mobility.

Some of the important features of Cisco IOS Software Release 12.2(33)SXI4 are

  • VSS Quad-Sup Uplink Forwarding help enable VSS customers to put four supervisors in the dual-chassis system to increase their uplink bandwidth.
  • Cisco EnergyWise allows IT and building facilities operations to optimize and control power across a corporate infrastructure.
  • Advanced Virtual Private LAN Services (A-VPLS) simplifies Data Center Interconnect deployments with rapid service provisioning.
  • Multicast Service Reflection (MSR) resolves overlapping IP addresses with multicast transmission of video or other feeds.
  • Service Advertisement Framework (SAF) helps you deploy and manage services across the network with greater scalability and flexibility.


May 25, 2011  5:17 AM

SUP 720 -3B Supervisor Engine Crashed

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

In my previous post I talked about the crashed Sup 720- 3B supervisor Engine for a Cisco Catalyst 6513 Switch. Since there was no ray of hope for the SUP 720-3B Supervisor Engine and I couldn’t make use of “show tech” IOS command. I decided to open a TAC case with Cisco.

The TAC Engineer after studying the logs generated by the crashed Sup 720- 3B supervisor Engine came up with the following reply

“Hello Yasir

It seems we have faulty SUP and need to be replaced since it is keep crashing and not coming up.”

After looking at the log’s I predict there might be problem with flash memory of SUP 720 -3B Supervisor Engine.

System Bootstrap, Version 8.1(3)

Copyright (c) 19 94-20 04 by cisco Systems, Inc.

Cat6k-Sup720/SP processor with 524288 Kbytes of main memory

rommon 1 >

I tried to boot the SUP 720-3B using the boot command from rommon mode but that too failed and I am getting the following error.

%DIAG-SP-6-RUN_MINIMUM: Module 7: Running Minimal Diagnostics…

Also I tried to boot the SUP 720-3B from the flash memory using the “bootflash:”command that too failed again I am getting the same error

%DIAG-SP-6-RUN_MINIMUM: Module 7: Running Minimal Diagnostics…


%Software-forced reload

Breakpoint exception, CPU signal 23, PC = 0×41D8BE6C

-Traceback= 41D8BE6C 41D89DB8 41B370D8 41B37104 41A09A1C 41A4ACCC 41A41000 41A41058 4075B9FC 4075C6E4 419168D8 419166F4 41AD8610 41AD5530 41AD574C 41D7E35C

$0 : 00000000, AT : 43100000, v0 : 44AF0000, v1 : 43640000

a0 : 50E46E18, a1 : 0000F100, a2 : 00000000, a3 : 42E30000

t0 : 41D7E978, t1 : 3400F101, t2 : 41D7E988, t3 : FFFF00FF

t4 : 41D7E978, t5 : 00000000, t6 : 00000000, t7 : 00000000

s0 : 00000000, s1 : 430B0000, s2 : 5033A36C, s3 : 087365C8

s4 : 50D740D0, s5 : 50D1AC48, s6 : 00000040, s7 : 43890000

t8 : 5000BA74, t9 : 00000009, k0 : 00000000, k1 : 00000000

gp : 431011F0, sp : 5000BB28, s8 : 00000000, ra : 41D89DB8

EPC : 41D8BE6C, ErrorEPC : 65DFF3A3, SREG : 3400F103

MDLO : 00000000, MDHI : 00000000, BadVaddr : 00000000

DATA_START : 0×42DDFAF0

Cause 00000024 (Code 0×9): Breakpoint exception

Writing crashinfo to bootflash:crashinfo_20110523-131601

=== Flushing messages (16:16:01 KSA Mon May 23 2011) ===

Buffered messages:

00:01:01: curr is 0×0

This is why Cisco is a leader among its competitor and they are exceling because they are pioneers of Networking. I love Cisco for two reasons strong technical support and commitment they show to the customer.


May 24, 2011  5:34 AM

Vulnerabilities reported in Cisco Unified Operations Manager and CiscoWorks Common Services

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

According Cyber Risk Report for this week lot of vulnerabilities, including Perl, Red Hat, Python and features updates from multiple vendors including Adobe, Citrix and Cisco Systems. For all those you are unaware of Cyber Risk report (CRR) is published by Cisco Security Intelligence Operations (SIO).

Cisco released two security advisories addressing five vulnerabilities in the Cisco Unified Operations Manager and CiscoWorks Common Services. These advisories and the latest vulnerability, threat, and mitigation recommendations are available on the Cisco Security Intelligence Operations website.

So security experts beware of these latest developments and make sure you are ready to face challenges as the spam activity has increased a lot and the spam message authors continue to create variations in their attempts to bypass ant spam protection and trick users into acting on the messages.


May 24, 2011  5:14 AM

SUP 720- 3B failing to boot

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Friends we have a Cisco Catalyst 6513 Switch installed with SUP 720-3B as a supervisor engine. From past 7 years its working fine but suddenly we the SUP 720-3B supervisor Engine failed. The SUP 720-3B is always going in to rommom mode and I am getting the following error

System Bo otstrap, Version 8.1(3)

Copyright (c) 19 94-20 04 by cisco Systems, Inc.

Cat6k-Sup720/SP processor with 524288 Kbytes of main memory

rommon 1 >

I tried to boot the SUP 720-3B using the boot command from rommon mode but that too failed and I am getting the following error.

%DIAG-SP-6-RUN_MINIMUM: Module 7: Running Minimal Diagnostics…

Also I tried to boot the SUP 720-3B from the flash memory using the “bootflash:”command that too failed again I am getting the same error

%DIAG-SP-6-RUN_MINIMUM: Module 7: Running Minimal Diagnostics…


%Software-forced reload

Breakpoint exception, CPU signal 23, PC = 0x41D8BE6C

-Traceback= 41D8BE6C 41D89DB8 41B370D8 41B37104 41A09A1C 41A4ACCC 41A41000 41A41058 4075B9FC 4075C6E4 419168D8 419166F4 41AD8610 41AD5530 41AD574C 41D7E35C

$0 : 00000000, AT : 43100000, v0 : 44AF0000, v1 : 43640000

a0 : 50E46E18, a1 : 0000F100, a2 : 00000000, a3 : 42E30000

t0 : 41D7E978, t1 : 3400F101, t2 : 41D7E988, t3 : FFFF00FF

t4 : 41D7E978, t5 : 00000000, t6 : 00000000, t7 : 00000000

s0 : 00000000, s1 : 430B0000, s2 : 5033A36C, s3 : 087365C8

s4 : 50D740D0, s5 : 50D1AC48, s6 : 00000040, s7 : 43890000

t8 : 5000BA74, t9 : 00000009, k0 : 00000000, k1 : 00000000

gp : 431011F0, sp : 5000BB28, s8 : 00000000, ra : 41D89DB8

EPC  : 41D8BE6C, ErrorEPC : 65DFF3A3, SREG     : 3400F103

MDLO : 00000000, MDHI     : 00000000, BadVaddr : 00000000

DATA_START : 0x42DDFAF0

Cause 00000024 (Code 0x9): Breakpoint exception

Writing crashinfo to bootflash:crashinfo_20110523-131601

=== Flushing messages (16:16:01 KSA Mon May 23 2011) ===

Buffered messages:

00:01:01: curr is 0x0

Seems like the SUP 720-3B is crashed, I will open a TAC case and see what the issue is. I know Cisco TAC team is quite helpful and they will come out with a solution for this problem. If anyone has any inputs or solutions they are welcome provide solutions in the comment area of this post.


May 22, 2011  5:15 AM

How to configure HRSP between Nexus 7000 and Cisco Catalyst 6500 Series Switches?

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Configuring HRSP in a Cisco Nexus 7000 Series Switch is often an easy task and it takes slight different approach. Recently we had some issues in our Data Centre and then I was forced to configuring the HSRP between a Cisco Nexus 7010 Switch and Cisco Catalyst 6506 E Switch. The configuration was quite simple, I would like to share the steps need to configure HSRP between a Cisco Nexus 7000 Series and Cisco Catalyst 6500 Series Switches.

In the below example I will configure HRSP for VLAN 34 with a subnet of 10.204.34.0/24

Cisco Catalyst 6500 Series Switch Configuration

Step 1 – Create VLAN 34 in Cisco Catalyst Switch and assign an IP Address

MBGF-DAC-6500-BB01(config)#interface vlan 34

MBGF-DAC-6500-BB01(config-if)#ip address 10.204.34.3 255.255.255.0

Step 2 – Configure HSRP group id, priority and timers, my active switch will be Cisco 6500 Switch due to its priority

MBGF-DAC-6500-BB01(config-if)# standby 34 ip 10.204.34.1

MBGF-DAC-6500-BB01(config-if)# standby 34 timers 1 3

MBGF-DAC-6500-BB01(config-if)# standby 34 priority 150

MBGF-DAC-6500-BB01(config-if)# standby 34 preempt

Cisco Nexus 7000 Series Switch Configuration

Step 1 – Create VLAN 34 in Cisco Nexus Switch and assign an IP Address

VDC-Admin-AG01-MB-1256-002(config)# interface vlan 34

VDC-Admin-AG01-MB-1256-002(config-if)# ip address 10.204.34.2/24

Step 2 – Configure HSRP group id, priority and timers , Nexus will be in standby mode

VDC-Admin-AG01-MB-1256-002(config-if)#hsrp 34

VDC-Admin-AG01-MB-1256-002(config-if-hsrp)# priority 110

VDC-Admin-AG01-MB-1256-002(config-if-hsrp)# timers 1 3

VDC-Admin-AG01-MB-1256-002(config-if-hsrp)# ip 10.204.34.1

Verify the HSRP States

Cisco Catalyst 6500 Switch Status

MBGF-DAC-6500-BB01:1#sho standby brief

P indicates configured to preempt.

|

Interface   Grp Prio P State    Active          Standby         Virtual IP

Vl34        34  150  P Init     local           10.204.34.3         10.204.34.1

MBGF-DAC-6500-BB01:1#

Nexus 7000 Series Switch HSRP Status

VDC-Admin-AG01-MB-1256-002# sho hsrp group 34

Vlan34 – Group 34 (HSRP-V1) (IPv4)

Local state is Standby, priority 110 (Cfged 110)

Forwarding threshold(for vPC), lower: 1 upper: 110

Hellotime 1 sec, holdtime 3 sec

Next hello sent in 0.179000 sec(s)

Virtual IP address is 10.204.34.1 (Cfged)

Active router is 10.204.34.2

Standby router is local

Virtual mac address is 0000.0c07.ac22 (Default MAC)

2 state changes, last state change 2d18h

IP redundancy name is hsrp-Vlan34-34 (default)

VDC-Admin-AG01-MB-1256-002#

Configuring HRSP is a quite a simple and if you are facing any problems configuring you can post your scenario in the comments area of this post.


May 15, 2011  4:50 AM

Cisco predicts weak quarter

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

Cisco CEO John Chambers expects Q4 sales growth will be between 0% to 2 %, which is much below the analyst expectations of 7%. Cisco Systems also warned they are looking to reduce the workforce with a target of saving S1 billion per year. Most of job cuts are most likely to come through an early retirement programs, already Cisco managed to shed 550 jobs with the closure of its Flip unit.

During a May 11 conference call to discuss quarterly financial numbers, both Cisco Chairman and CEO John Chambers and COO Gary Moore said job cuts were on the way as the networking giant tries to get back on solid footing after several disappointing quarters.

For the last quarter which ended  30th April, Cisco reported sales were up 4.8% to $10.9 billion, although income was down 17.6% to $1.8bn from $2.2bn in the same period of 2010.

“This quarter played out as we expected,” said Chambers. “We have acknowledged our challenges. We know what we have to do. We have a clear game plan, and we are a company with a track record of market-shaping innovation.”

I expect Cisco to concentrate on their core technologies and products which are quite popular worldwide; especially in Middle East Cisco is a networking pioneer.


May 10, 2011  5:13 AM

HP debuts “Toner Cartridge Authentication Software”

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

At least in this part of World counterfeiting printer cartridges has become a common activity. To tackle this issue HP becomes the first company in the world to debut Toner Cartridge Authentication software. The goal of the software is to detect counterfeit toner cartridges and alert the user that the cartridge is not an original HP brand cartridge

The newly announced Toner Cartridge Authentication software is comprised of three components working together. The smart chip technology contains authentication information which is collected by the Authentication software and transmitted to the authentication web service. That service then checks the data and once it is validated, it is sent back to the software, which shows the result in a pop-up box on a users’ screen. Guess what the whole process takes about a minute, amazing!

The software can be downloaded from HP for LaserJet printers, Inkjet printers already have the software embedded within the firmware. Currently  the 1000, 2000 and 3000 series LaserJet printers are supported and by 2012 HP hoping support all the HP products that comes under the ink segment.

“Either you get a message saying no risk detected, all packages are original or you get a big, bold risk detected message. If you get the risk detected message, we suggest you also click the link directly to the anti-counterfeit page,” said Andrea Gebhard, LaserJet Supplies, Imaging and Printing Group, Middle East, Mediterranean and Africa.

According to HP in the span of four years they discovered more than 30 million counterfeit products worldwide.

In addition to the Cartridge Authentication Software, HP advises that there are three basic steps that every user of HP supplies can take to identify the authenticity of an HP product, including checking for holographic security labels on the packaging tabs, checking the quality of the packaging and checking the quality and finish of the cartridge itself.


April 30, 2011  6:45 AM

Resequence the access-list!

Yasir Irfan Yasir Irfan Profile: Yasir Irfan

When it comes to modifying Access lists in Cisco IOS devices most of us remove the ACL’s from the Cisco Router and then edit the entries in a note, and then paste back the modified ACL to the respective router via CLI.

There is a way to reduce the overhead involved in modifying ACL by using the Cisco IOS feature of resequencing.

In the following example in a Cisco router there is an access-list name ITKE

ASW2-02#sho access-lists ITKE

Extended IP access list ITKE

1 permit ip host 192.168.1.1 host 10.1.0.1

2 permit ip host 192.168.1.2 host 10.1.0.2

ASW2-02#

From the example if we need to add one more deny statement for the host 192.168.1, it’s not possible to add a statement without deleting the current access list and create a new one. But the power of resequence allows you to assign a new set of sequence numbers to current access list as demonstrated below using the IOS command “ip access-list resequence”

ASW2-02#configure t

ASW2-02(config)#ip access-list resequence ITKE ?

<1-2147483647>  Starting Sequence Number

ASW2-02(config)#ip access-list resequence ITKE 10 10

This starts the first entry with a sequence number of 10 and increments all new lines by 10. The result is as shown below

ASW2-02#sho ip access-lists ITKE

Extended IP access list ITKE

10 permit ip host 192.168.1.1 host 10.1.0.1

20 permit ip host 192.168.1.2 host 10.1.0.2

ASW2-02#

By resequencing the ACL now it’s easy to inserts a new ACL with a sequence number of 15 which would fall between the existing entries in the ITKE access list.


Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: