The Journey of a Network Engineer

Oct 31 2010   2:39PM GMT

From trunk ports to routed ports – part 3



Posted by: Sulaiman Syed
Tags:
access
Cisco
client
configuration
core
design
distribution
network
routed
switch
trunk
vtp

This is the final part of the series. In this blog entry, I would post the sequence and the configuration lines that are needed to be done in order to have smooth transition from trunk ports to routed ports. The motive to change from trunk ports to routed ports can be read in part 1 , while the part two covered the network design scheme.

Implementation Plan:

The implementation will be carried in specific number of steps. The following syntax will give a general configuration which later on can be changed depending on IP addresses, switches, and number of links.

First Step: configuring IP addressed and default gateways in all network devices
en
conf t
int vlan 1
ip address 10.0.yy.xx 255.255.255.0 (where yy is distribution switch location, xx is switch number)
exit
ip default gateway 10.254.yy.1 (where yy is distribution switch location)
Second Step: configuring STP root on distribution switch.
en
conf t
spanning-tree vlan xx priority 4096 (do for all respective vlans in that building)
Third Step: configuring STP root on second distribution switch if available.
en
conf t
spanning-tree vlan xx priority 8192 (do for all respective vlans in that building)
Fourth Step: configuring the routing protocol on core switches.
en
conf t
router eigrp 10
network 10.0.0.0
Fifth Step: configuring the ports on core switches.
en
conf t
int gig x/x (x/x is the interface number)
no switchport
ip address 10.1.255.254 255.255.255.252
Sixth Step: configuring the routing protocol on distribution switch.
en
Conf t
router eigrp 10
network 10.0.0.0
Seventh Step: configuring the ports on distribution switch.
en
conf t
int gig x/x (x/x is the interface number)
no switchport
ip address 10.1.255.253 255.255.255.252
Eighth Step: configuring distribution switch for VTP
en
conf t
vtp mode server
vtp domain VTPDOMAIN
no vlan x,x-x (where x is the vlan numbers wanted to be removed)
Ninth Step: configuring access switch for VTP
en
conf t
vtp mode client
vtp domain VTPDOMAIN
Step four to step five can be combined. Step six to eight can be done in one instance as well. Since most of distribution switches do have two links, it will not be necessary to go to the building physically. Buildings that have single link connecting distribution switch to core switch will require the presence physically at both ends.

 Comment on this Post

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when other members comment.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: