The Journey of a Network Engineer

Oct 11 2010   6:48AM GMT

Connecting your PC to GNS3

Sulaiman Syed Profile: Sulaiman Syed

In this entry, we would see how to connect a router from the GNS3 simulator to your pc.

This will help you with all the basic simulations using SDM, it is specially good for people taking the CCNA Security exam.

First, we would need loopback interface in your PC. The following steps are used to create the loopback interface:

1. Go to Control Panel–>Add Hardware then click Next
2. Yes I have already connected the hardware
3. Scroll to the bottom and click on Add a new hardware device then Next
4. Install the hardware that I manually select from a list (Advanced)
5. Click on Network Adapters then Next
6. Select Microsoft as the Manufacturer then on Microsoft Loop-back Adapter under Network Adapter then click Next then Next again.
7. Open up Control Panel–>Network Connections to see the adapter in place.

Once that is done. Now run your GNS3 simulator, and do the following.

1- Drag the Cloud shape into the screen.
2-Right click, and configure.
3-go to the designated cloud (usually C1)
4-click on the Generic ethernet NIO
5-Select the Microsoft Loop-back Adapter, then ADD

Now, all you need to do, is add the router. connect a link between the Cloud and router. and you would be able to use SDM, of course you would still need to configure the router. Configuring the router will be in part 2 of this entry.

2  Comments on this Post

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when other members comment.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • nsikosamuel
    I have tried this configuration in GNS3 but for some reason the router is not able to ping the cloud and yet I finished connecting the cloud with ip address 192.168.200.2/24 but can ping the network address which is 192.168.200.1/24 on which the cloud is directly connected.
    enable
    configure terminal
    router rip
    network 192.168.100.0
    network 192.168.200.0
    exit
    exit
    configure terminal
    interface FastEthernet0/0
    ip address 192.168.100.1 255.255.255.0
    no shutdown
    exit
    interface FastEthernet0/1
    ip address 192.168.200.1 255.255.255.0
    no shutdown
    exit
    exit
    enable
    configure terminal
    ip dhcp excluded-address 192.168.100.1 192.168.100.10
    ip dhcp pool cyber
    network 192.168.100.0 255.255.255.0
    default-router 192.168.100.1
    dns-server 192.168.200.2
    exit
    exit
    0 pointsBadges:
    report
  • Sulaiman Syed
    Hi, i dont quite understand what you said. Can you ping from the router to the cloud (PC)? Can you ping from the PC (Cloud) to the router? have you followed all the steps in creating the loopback interface in the PC?
    130 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

Share this item with your network: