Network Administrator Knowledgebase


June 8, 2008  12:02 AM

Remote Desktop Connection 6.1 (RDP 6.1) on Windows XP WITHOUT SP3. RDP 6.1 on Win XP with SP2

Michael Khanin Michael Khanin Profile: Michael Khanin

Recently, on one Windows 2008 I’ve installed a Terminal Server Role and did a TS Web Apps. Really nice feature, you can get access to application through web interface, exactly how it’s done on Citrix, but by using Windows 2008 you not requested to buy a Citrix ;). Yes, TS Web Apps from Windows 2008 is a nice, but to get access to this application, on a client side should be installed RDP 6.1 client. This particular version of RDP cames with SP3 for Windows XP or with SP1 for Windows Vista. I have no idea why Microsoft doesn’t provide RDP 6.1 as separate package.
In my case I couldn’t install XP SP3 or Vista SP1 on every machine in Network, so I’ve found a workaround. The first step is to install a RDP 6.0. After that we need to get few files from XP SP3 or Vista SP1. Create anywhere on your disk directory, let’s say RDP6_1 and put there the following files:

lhmstsc.mui
lhmstscx.mui
mstsc.chm
mstsc.exe
mstsc.exe.mui
mstscax.dll

Inside RDP6_1 create directory en-us and put there the following files:

aaclient.dll.mui
mstsc.exe.mui
mstscax.dll.mui

NOTE: Remember to take all mentioned files from Windows XP SP3 or from Windows Vista SP1.

Now inside RDP6_1 create a batch update.bat. Here is a content of update.bat :

del c:\windows\$ntservicepackuninstall$\mstsc.exe
del c:\windows\$ntuninstallkb925876$\mstsc.exe
del c:\windows\servicepackfiles\i386\mstsc.exe
del c:\windows\system32\mstsc.exe
del c:\windows\system32\dllcache\mstsc.exe
del c:\windows\lastgood\system32\mstsc.exe

del c:\windows\$ntservicepackuninstall$\mstscax.dll
del c:\windows\$ntuninstallkb925876$\mstscax.dll
del c:\windows\servicepackfiles\i386\mstscax.dll
del c:\windows\system32\mstscax.dll
del c:\windows\system32\dllcache\mstscax.dll
del c:\windows\lastgood\system32\mstscax.dll

copy mstsc.exe c:\windows\$ntservicepackuninstall$\mstsc.exe
copy mstsc.exe c:\windows\$ntuninstallkb925876$\mstsc.exe
copy mstsc.exe c:\windows\servicepackfiles\i386\mstsc.exe
copy mstsc.exe c:\windows\system32\mstsc.exe
copy mstsc.exe c:\windows\system32\dllcache\mstsc.exe
copy mstsc.exe c:\windows\lastgood\system32\mstsc.exe

copy mstscax.dll c:\windows\$ntservicepackuninstall$\mstscax.dll
copy mstscax.dll c:\windows\$ntuninstallkb925876$\mstscax.dll
copy mstscax.dll c:\windows\servicepackfiles\i386\mstscax.dll
copy mstscax.dll c:\windows\system32\mstscax.dll
copy mstscax.dll c:\windows\system32\dllcache\mstscax.dll
copy mstscax.dll c:\windows\lastgood\system32\mstscax.dll

xcopy *.* c:\windows\system32 /e /y
regsvr32 %systemroot%\system32\mstscax.dll /s


Update.bat
should be run after installation of RDP 6.0
Now, you can navigate to your TS Web Access and run RemoteApp Program.

May 29, 2008  11:10 PM

AccessChk v4.1

Michael Khanin Michael Khanin Profile: Michael Khanin

Mark Russinovich released a new very nice tool for IT Pro (System Administrators), AccessChk v4.1.
Windows administrators often need to know what kind of accesses specific users or groups have to resources including files, directories, Registry keys, global objects and Windows services. AccessChk quickly answers these questions with an intuitive interface and output.

Examples

The following command reports the accesses that the Power Users account has to files and directories in \Windows\System32:

accesschk “power users” c:\windows\system32

This command shows which Windows services members of the Users group have write access to:

accesschk users -cw *

To see what Registry keys under HKLM\CurrentUser a specific account has no access to:

accesschk -kns austin\mruss hklm\software

To see the security on the HKLM\Software key:

accesschk -k hklm\software

To see all files under \Users\Mark on Vista that have an explicit integrity level:

accesschk -e -s c:\users\mark

To see all global objects that Everyone can modify:

accesschk -wuo everyone \basednamedobjects


May 29, 2008  1:15 PM

Sysinternals Live – Execute Sysinternals Tools Directly from the Web

Michael Khanin Michael Khanin Profile: Michael Khanin

The Beta of Sysinternals Live was announced today. A service that enables you to execute Sysinternals Tools directly from the web without manually downloading them. Enter a tool’s Sysinternals Live path into Windows Explorer or a command prompt as \\live.sysinternals.com\tools\<toolname>
View the entire Sysinternals Live Tools directory in a browser at http://live.sysinternals.com.


May 21, 2008  3:17 AM

Remote Server Administration Tools for Vista SP1 has been released. ALL server languages!

Michael Khanin Michael Khanin Profile: Michael Khanin

Language

X86

X64

German

German – Germany

German – Germany

Japanese

Japanese – Japan

Japanese – Japan

Spanish

Spanish (Traditional Sort) – Spain

Spanish (Traditional Sort) – Spain

French

French – France

French – France

Chinese

Chinese – China

Chinese – China

Italian

Italian – Italy

Italian – Italy

Chinese – Taiwan

Chinese – Taiwan

Chinese – Taiwan

Chinese – Hong Kong

Chinese – Hong Kong SAR

Chinese – Hong Kong SAR

Russian

Russian – Russia

Russian – Russia

Korean

Korean – Korea

Korean – Korea

Portuguese

Portuguese – Brazil

Portuguese – Brazil

Dutch

Dutch – Netherlands

Dutch – Netherlands

Swedish

Swedish – Sweden

Swedish – Sweden

Portuguese

Portuguese – Portugal

Portuguese – Portugal

Polish

Polish – Poland

Polish – Poland

Turkish

Turkish – Turkey

Turkish – Turkey

Czech

Czech – Czech Republic

Czech – Czech Republic

Hungarian

Hungarian – Hungary

Hungarian – Hungary


May 21, 2008  2:58 AM

I’m MCITP: Server Administrator & Enterprise Administrator

Michael Khanin Michael Khanin Profile: Michael Khanin

Yes, finally I’ve finished with all my exams and I’m now a MCITP Server Administrator & Enterprise Administrator :).


May 21, 2008  2:45 AM

PowerShell on Windows Server 2008 Core Edition

Michael Khanin Michael Khanin Profile: Michael Khanin

Everybody, who just started deal with Windows 2008 knows a very nice (IMHO) version, Windows 2008 core. One of the things, that I , and not just I, do not love, Core Editions of Windows 2008 doesn’t support PowerShell. Equally, we can use PowerShell with Windows 2008 Core, but just from remote computer. Dmitry Sotnikov, MVP in PowerShell, published step-by-step instruction on installing Windows PowerShell on Windows Server 2008 in Server Core mode. To know how to do this, go to Dmitry Sotnikov’s PowerBlog.


May 21, 2008  2:33 AM

SBS and EBS videos on Technet Edge

Michael Khanin Michael Khanin Profile: Michael Khanin

There are new demonstration videos of the upcoming Small Business Server 2008 and Essential Business Server 2008 on TechNet Edge.


May 21, 2008  2:29 AM

Hyper-V RC1 Release Available

Michael Khanin Michael Khanin Profile: Michael Khanin

Update for Windows Vista (KB949587) 

Update for Windows Server 2008 x64 Edition (KB950049)

The Release Candidate 1 (RC1) update to the Hyper-V role provides improvements to security, stability, performance, user experience, forward compatibility of configurations, and the programming model.

Update for Windows Vista for x64-based Systems (KB949587) 

Install this update to enable remote management of a Windows Server 2008 computer running the Hyper-V RC1 role.


May 19, 2008  10:12 PM

Microsoft Virtual PC 2007 with SP1

Michael Khanin Michael Khanin Profile: Michael Khanin

Few days ago Microsoft released a Microsoft Virtual PC 2007 with SP1. This update for Microsoft Virtual PC 2007 includes support for the following additional Host and Guest Operating Systems:

Additonal Guest Operating System support
:
Windows Vista® Ultimate Edition with Service Pack 1 (SP1)
Windows Vista® Business Edition with Service Pack 1 (SP1)
Windows Vista® Enterprise Edition with Service Pack 1 (SP1)
Windows Server® 2008 Standard
Windows XP Professional with Service Pack 3

Additional Host Operating System support:
Windows Vista® Ultimate Edition with Service Pack 1 (SP1)
Windows Vista® Business Edition with Service Pack 1 (SP1)
Windows Vista® Enterprise Edition with Service Pack 1 (SP1)
Windows XP Professional with Service Pack 3

Download from here


May 15, 2008  1:55 AM

BGP

Michael Khanin Michael Khanin Profile: Michael Khanin

BGP is the protocol that binds the Internet together. It is what sends one packet across the globe in a few milliseconds and allows you to send email, . Typically, you will see Cisco routers that will handle this sort of heavy lifting and that is the IOS that we will review briefly.

ASNStarting point
In order to have a BGP connection you will need to have an ASN(Autonomous System Number). You can get one of these through ARIN (American Registry for Internet Numbers). BGP uses ASN’s like VLAN id’s or a higher level view of subnetting. There are private ASN’s if you are planning on using BGP for internal purposes only. The private BPG range is AS64512 through to AS65535.

IOSConfiguration info
Here is the basic output of two connections to two different autonomous systems from one Cisco router.

router bgp 64512
no synchronization
bgp log-neighbor-changes
bgp dampening
network 3.3.3.0
neighbor 1.1.1.1 remote-as AS64513
neighbor 1.1.1.1 description Provider 1 >>Provider 1 Support Line<<
neighbor 1.1.1.1 password 7 09823490822093482F
neighbor 1.1.1.1 update-source Loopback1
neighbor 1.1.1.1 version 4
neighbor 1.1.1.1 route-map Provider1 out
neighbor 2.2.2.2 remote-as AS64514
neighbor 2.2.2.2 description Provider 2 >>Provider 2 Support Line<<
neighbor 2.2.2.2 password 7 09823490822093482F
neighbor 2.2.2.2 update-source Loopback2
neighbor 2.2.2.2 version 4
neighbor 2.2.2.2 weight 50
Let’s walk through the configuration a bit. Here are the same commands but with comments added in at various places

! This line is telling the BGP router which ASN it should advertise.
! A Cisco BGP router can only administer one ASN at a time.
router bgp 64512

! Log the changes when the neighbor goes up and down.
! This way you can see if the other BGP router that you are peering with is stable.
bgp log-neighbor-changes

! This is the network that you are advertising via BGP
network 3.3.3.0
! This is the ASN of your ISP or peered BGP network.
neighbor 1.1.1.1 remote-as AS64513
! While you don’t technically need this line it is important that you use it
! for your own clarification
neighbor 1.1.1.1 description Provider 1 >>Provider 1 Support Line<<
! Encrypted password for transferring your BGP data back and forth with your peer.
! Encrypting your BGP data will ensure that no one hijacks you routers.
neighbor 1.1.1.1 password 7 0934099082282F8234
! Using a loop back interface will ensure that the BGP peer always sees one
! interface that is in the network that you are advertising as being up.
! This will always keep the peering with your ISP up.
neighbor 1.1.1.1 update-source Loopback1
! The version of BGP that you are using. Version 4 is the most widely used and most recent.
neighbor 1.1.1.1 version 4
neighbor 1.1.1.1 route-map Provider1 out
As a final note, BGP is a powerful protocol with lots of features and options. However, most ISP’s don’t support the full suite of options that BGP provides so don’t expect to use all of them in order to shape your traffic.


Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to: