Logitech webcam is not connected

5 pts.
Tags:
Logitech
Webcam
I own a Logitech C170 webcam, and I'm trying to use it for various things but am having issues. When I open the webcam recorder in Movie Maker, it shows perfectly, and functions as it should, but when I've tried to use other things such as OBS and Chrome (for omegle), it shows a black screen and says it's connected. There is a light that indicates whether or not it is sending a signal, and when trying to use OBS or Chrome, the light flashes for a brief moment and then shuts back off. I've checked the drivers, they are all properly installed and up to date. I've checked my antivirus and it is not blocking it either. I've tried unplugging it, switching USB ports, restarting my PC, and everything else I've read that said it would fix it.

Software/Hardware used:
Logitech C170 Webcam, HP Envy 700-074, Windows 8.1

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.
  • Subhendu Sen
    In some cases, some webcam program's settings will be reset/skewed after updating OS (if any). If that happened, open webcam's program/ setup and find Preferences/ Settings, & adjust the video/ display settings to see if the webcam's picture changes.
    96,850 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

Thanks! We'll email you when relevant content is added and updated.

Following

Share this item with your network: