I want a autofallback of link from BGP to OSPF

5 pts.
Tags:
BGP
Cisco 1841
OSPF
Hi , I have a cisco 1841 router connected to 2 different isp & running 2 different protocol (ospf & bgp). I want to use ospf link as a primary & auto switch to bgp link in case of pri link failure. I have added static route to make ospf link pri  & it works but unable to auto switch. Attached here is a my router configuration. Please help me on this.
Password:
Lalbaug#sh run
Building configuration...

Current configuration : 3643 bytes
!
! Last configuration change at 11:59:32 UTC Thu Apr 26 2012 by dco
! NVRAM config last updated at 11:59:36 UTC Thu Apr 26 2012 by dco
! NVRAM config last updated at 11:59:36 UTC Thu Apr 26 2012 by dco
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Lalbaug
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$0yHB$jb5PqUvpTkwFwVzdG1Lvm1
!
no aaa new-model
!
no ipv6 cef
ip source-route
ip cef
!
!
!
!
!
no ip domain lookup
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
license udi pid CISCO1921/K9 sn FGL153820UY
!
!
username dco password 7 00071E1555095826
username acbl privilege 15 secret 5 $1$TMOo$jyp.67iui.iacLci/MId70
username cisco password 7 110A1016141D
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description "Connected to local Lan"
ip address 192.168.43.158 255.255.255.224
ip access-group server-accces in
ip accounting output-packets
duplex auto
speed auto
!
interface GigabitEthernet0/1
description " connected to tulip "
ip address 10.235.17.106 255.255.255.252
duplex auto
speed auto
!
interface Serial0/0/0
description "Connected to  HO"
ip address 192.168.200.29 255.255.255.252
encapsulation ppp
no fair-queue
!
router ospf 100
network 192.168.43.128 0.0.0.31 area 1
network 192.168.200.28 0.0.0.3 area 1
!
router bgp 64505
 bgp log-neighbor-changes
network 192.168.43.128
neighbor 10.235.17.105 remote-as 65500
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 192.168.70.0 255.255.255.0 192.168.200.30
ip route 192.168.100.0 255.255.255.128 192.168.200.30
!
ip access-list extended server_access
deny   tcp 192.168.43.128 0.0.0.31 192.168.100.0 0.0.0.255 eq telnet
deny   tcp 192.168.43.128 0.0.0.31 192.168.101.0 0.0.0.255 eq telnet
permit ip any any
!
!
!
!
control-plane
!
!
privilege exec level 8 isdn call interface
privilege exec level 8 isdn call
privilege exec level 8 isdn test call interface
privilege exec level 8 isdn test call
privilege exec level 8 isdn test
privilege exec level 8 isdn
privilege exec level 8 show isdn active
privilege exec level 8 show isdn status
privilege exec level 8 show isdn
privilege exec level 8 show interfaces
privilege exec level 8 show
privilege exec level 8 clear counters
privilege exec level 8 clear
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
session-timeout 5
exec-timeout 5 0
login local
transport input telnet
!
scheduler allocate 20000 1000
end
Regards, Chandrakant S

Software/Hardware used:
autofall back of BGP link in cisco router

Answer Wiki

Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Discuss This Question: 3  Replies

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • Santucci44
    Create a second static route for the bgp link with the second best AD. Right now your eBGP has an AD of 170 and you iBGP has an AD of 200 which are the worst paths to take in the routers eyes. Your static routes have the best AD of 1, and in the eyes of the router, is the best and most believable path. You can also do some policy based routing to get it working.
    120 pointsBadges:
    report
  • Cisc0tech
    Hi, if you have added static route on OSPF and will also add a static route on BGP means you are no more using OSPF/BGP for learning routes. This will work, but only for outgoing traffic. So basically you will end up with sending traffic via OSPF and receiving via BGP. Asymetric Routing. I think you should try policy based routing.. something like modifying AD, try 'distance' command to decrease OSPF's AD or increase BGP AD. Search for IP SLA feature.. what you can do is on the BGP neighbor put a tracking for OSPF link, when the OSPF link goes down, IP SLA will bring up the BGP neighborship ;) but yes failover will take about 30-50 seconds as BGP takes time to form neighborship.
    45 pointsBadges:
    report
  • fssf97df
    Hi,

    I think IP SLA is what you need
    10 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following