VPN over dynamic IP address

357170 pts.
Tags:
Code
IPsec
IPsec Passthrough
IPsec VPN
Linksys
Networking
Networking Equipment
SVN
VPN
I want to host my source code control environment (SVN) on a server at home, accessible through VPN. I have a dynamic IP address. Does anyone have suggestions for hardware (router/servers) and software. Looking to keep a low expense, but something that will get the job done well. I have a Linksys WRT54G broadband router supporting IPSec passthrough. Should I upgrade?

Answer Wiki

Thanks. We'll let you know when a new response is added.

You can do what you want with a ‘dynamic DNS’ service. That gives you a host name which can refer to your home’s dynamic IP address. You run a piece of software on your PC or router that signs in to the dynamic DNS service and keeps it updated with your current IP address. Totally doable.

You may have a great router, especially if flashed with DD-WRT. If it is, then you can set it up to automatically update your dynamic DNS account, and not rely on your PC to do it. That’s how mine is set up.

Here’s the dynamic DNS service I use (I use a free account).

And, here’s the link to DD-WRT (if you are interested, as it is optional). You’ll have to see if your particular model of WRT54G is supported or not.

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • nickwestin
    SITE_A
    Router>en
    Router#conf t
    Router(config)#hostname SITE_A

    SITE_A(config)#int fa0/0 
    SITE_A(config-if)#ip add
    SITE_A(config-if)#ip address 193.85.97.122 255.255.255.252
    SITE_A(config-if)#no shut

    SITE_A(config)#int lo0
    SITE_A(config-if)#ip address 172.16.0.1 255.255.0.0
    SITE_A(config-if)#int lo1
    SITE_A(config-if)#ip address 172.17.0.1 255.255.0.0

    SITE_A(config)#interface tunnel 1
    SITE_A(config-if)#ip address 192.168.10.101 255.255.255.252
    SITE_A(config-if)#tunnel source fa0/0
    SITE_A(config-if)#tunnel destination 201.55.196.222

    SITE_A(config)#router eigrp 1
    SITE_A(config-router)#no auto-summary 
    SITE_A(config-router)#network 172.16.0.1 0.0.255.255 
    SITE_A(config-router)#network 172.17.0.1 0.0.255.255 
    SITE_A(config-router)#network 192.168.10.100 0.0.0.3 

    SITE_A(config)#ip route 0.0.0.0 0.0.0.0 193.85.97.121

    SITE_A(config)#crypto isakmp policy 10
    SITE_A(config-isakmp)#authentication pre-share 
    SITE_A(config-isakmp)#encryption aes 256 
    SITE_A(config-isakmp)#hash sha
    SITE_A(config-isakmp)#Group 5 
    SITE_A(config-isakmp)#Lifetime 3600

    SITE_A(config)#crypto isakmp key cisco address 201.55.196.222
    SITE_A(config)#crypto ipsec transform-set 55 esp-aes 256 esp-sha-hmac 

    SITE_A(config)#access-list 101 permit gre host 193.85.97.122 host 201.55.196.222

    SITE_A(config)#crypto map MYMAP 10 ipsec-isakmp 
    SITE_A(config-crypto-map)#match address 101
    SITE_A(config-crypto-map)#set peer 201.55.196.222
    SITE_A(config-crypto-map)#set transform-set 50

    SITE_A(config)#int fa0/0
    SITE_A(config-if)#crypto map MYMAP


    SITE_B
    Router>en
    Router#conf t
    Router(config)#hostname SITE_B

    SITE_B(config)#int fa0/1
    SITE_B(config-if)#ip address 201.55.196.222 255.255.255.252

    SITE_B(config-if)#int lo0
    SITE_B(config-if)#ip address 172.18.0.1 255.255.0.0
    SITE_B(config-if)#int lo1
    SITE_B(config-if)#ip address 172.19.0.1 255.255.0.0

    SITE_B(config)#interface tunnel 1
    SITE_B(config-if)#ip address 192.168.10.102 255.255.255.252
    SITE_B(config-if)#tunnel source fa0/1
    SITE_B(config-if)#tunnel destination 193.85.97.122

    SITE_B(config)#router eigrp 1
    SITE_B(config-router)#no auto-summary 
    SITE_B(config-router)#network 172.18.0.1 0.0.255.255
    SITE_B(config-router)#network 172.19.0.1 0.0.255.255
    SITE_B(config-router)#network 192.168.10.100 0.0.0.3

    SITE_B(config)#ip route 0.0.0.0 0.0.0.0 201.55.196.221

    SITE_B(config)#crypto isakmp policy 10
    SITE_B(config-isakmp)#authentication pre-share 
    SITE_B(config-isakmp)#encryption aes 256
    SITE_B(config-isakmp)#hash sha 
    SITE_B(config-isakmp)#Group 5
    SITE_B(config-isakmp)#Lifetime 3600

    SITE_B(config)#crypto isakmp key cisco address 193.85.97.122
    SITE_B(config)#crypto ipsec transform-set 50 esp-aes 256 esp-sha-hmac 

    SITE_B(config)#access-list 101 permit gre host 201.55.196.222 host 193.85.97.122

    SITE_B(config)#crypto map MYMAP 10 ipsec-isakmp
    SITE_B(config-crypto-map)#match address 101
    SITE_B(config-crypto-map)#set peer 193.85.97.122
    SITE_B(config-crypto-map)#set transform-set 50

    SITE_B(config)#interface fa0/1
    SITE_B(config-if)#crypto map MYMAP


    ISP
    Router>en
    Router#conf t
    Router(config)#hostname ISP

    ISP(config-if)#int fa0/0
    ISP(config-if)#ip address 193.85.97.121 255.255.255.252
    ISP(config-if)#int fa0/1
    ISP(config-if)#ip address 201.55.196.221 255.255.255.252

    10 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

Share this item with your network:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following