Vlan trunking, L3 switch + L2 switch problem

120 pts.
Tags:
L3 Switches
Switches
VLAN
VLAN trunking
Hi, I have now successfully got my PowerConnect 6224 configured, to host and route between 4 Vlans, I have internet access and can ping what I need to, it's all working great. The next thing on my list is configuring my L2 netgear router to work with port based Vlans, I want to connect the L2 switch to port 1/g23 on my PowerConnect 6224, as far as I understand this port needs to be a trunk port that allowes all Vlans, here is my config for the PowerConnect 6224: !Current Configuration: !System Description "Dell 24 Port Gigabit Ethernet, 2.0.1.8, VxWorks5.5.1" !System Software Version 2.0.1.8 ! configure vlan database vlan 10,20,30 vlan association subnet 192.168.1.0 255.255.255.0 1 vlan association subnet 192.168.2.0 255.255.255.0 10 vlan association subnet 192.168.20.0 255.255.255.0 20 vlan association subnet 192.168.30.0 255.255.255.0 30 exit stack member 1 1 exit switch 1 priority 1 ip address 192.168.1.1 255.255.255.0 ip domain-name xxx.xx.xx ip name-server 192.168.2.10 ip name-server 192.168.2.30 ip routing ip route 0.0.0.0 0.0.0.0 192.168.2.201 bootpdhcprelay enable bootpdhcprelay serverip 192.168.2.10 bootpdhcprelay cidridoptmode ip helper-address 192.168.2.1 192.168.2.10 37 ip helper-address 192.168.2.1 192.168.2.10 49 ip helper-address 192.168.2.1 192.168.2.10 137 ip helper-address 192.168.2.1 192.168.2.10 138 ip helper-address 192.168.20.1 192.168.2.10 37 ip helper-address 192.168.20.1 192.168.2.10 49 ip helper-address 192.168.20.1 192.168.2.10 137 ip helper-address 192.168.20.1 192.168.2.10 138 ip helper-address 192.168.30.1 192.168.2.10 37 ip helper-address 192.168.30.1 192.168.2.10 49 ip helper-address 192.168.30.1 192.168.2.10 137 ip helper-address 192.168.30.1 192.168.2.10 138 interface vlan 10 name "Servers" routing ip address 192.168.2.1 255.255.255.0 ip rip send version rip1 ip irdp exit interface vlan 20 name "Sales" routing ip address 192.168.20.1 255.255.255.0 ip rip send version rip1 ip irdp exit interface vlan 30 name "Accounts" routing ip address 192.168.30.1 255.255.255.0 ip netdirbcast ip rip send version rip1 ip irdp exit username "michi" password 4f70cfb1451a1b0ce0b872421bee6c1c level 15 encrypted ! interface ethernet 1/g1 switchport mode general switchport general pvid 10 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10,20,30 exit ! interface ethernet 1/g3 switchport mode general switchport general pvid 10 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10,20,30 exit ! interface ethernet 1/g4 switchport mode general switchport general pvid 20 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 20 exit ! interface ethernet 1/g5 switchport mode general switchport general pvid 10 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10,20,30 exit ! interface ethernet 1/g7 switchport mode general switchport general pvid 10 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10 exit ! interface ethernet 1/g8 switchport mode general switchport general pvid 30 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 30 exit ! interface ethernet 1/g23 switchport mode trunk switchport trunk allowed vlan add 1,10,20,30 exit ! interface ethernet 1/g24 switchport mode general switchport general pvid 10 no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10,20,30 exit exit On my netgear L2 switch i want to connect port 24 to 1/g23 of my Dell switch, but I can't seem to be able to get it to work somehow, here is my config of the Netgear switch: !Current Configuration: ! !System Description "GSM7224 L2 Managed Gigabit Switch" !System Description 6.2.0.14 ! set prompt "GSM7224" network protocol none network parameters 192.168.1.2 255.255.255.0 192.168.1.1 vlan database vlan 10 vlan name 10 Servers vlan 20 vlan name 20 Sales vlan 30 vlan name 30 Accounts exit configure clock timezone 'GMT' 0 0 sntp client mode unicast ! sntp server status is active sntp server PooleOne.xxx.xx.xx logging buffered lineconfig exit storm-control flowcontrol spanning-tree configuration name 00-0F-B5-FC-BA-62 snmp-server community public@10 snmp-server community public@20 snmp-server community public@30 ip domain-name xxx.xx.xx ip name-server 192.168.2.10 192.168.2.30 192.168.2.201 interface 0/1 vlan pvid 10 vlan participation include 10 exit interface 0/2 vlan pvid 20 vlan participation include 20 exit interface 0/3 vlan pvid 30 vlan participation include 30 exit interface 0/4 exit interface 0/5 exit interface 0/6 exit interface 0/7 exit interface 0/8 exit interface 0/9 exit interface 0/10 exit interface 0/11 exit interface 0/12 exit interface 0/13 exit interface 0/14 exit interface 0/15 exit interface 0/16 exit interface 0/17 exit interface 0/18 exit interface 0/19 exit interface 0/20 exit interface 0/21 exit interface 0/22 exit interface 0/23 exit interface 0/24 description 'Trunk Port' vlan tagging 1 vlan participation include 10 vlan tagging 10 vlan participation include 20 vlan tagging 20 vlan participation include 30 vlan tagging 30 exit exit First; is it possible to accomplish what I'm trying to do with my equipment? Second; where have i gone wrong in my configs? Thank you very much for your help.
ASKED: April 7, 2008  10:53 AM
UPDATED: February 16, 2011  2:06 PM

Answer Wiki

Thanks. We'll let you know when a new response is added.

This setup is working fine, it was my DHCP servers Fault!!
Doooooooohhhhhhhhhh!!!!!!!!!!!!!!!

—————————
(glad we could help)

Discuss This Question: 1  Reply

 
There was an error processing your information. Please try again later.
Thanks. We'll let you know when a new response is added.
Send me notifications when members answer or reply to this question.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
  • MyMammothTech
    I am trying to do something along the same lines. I have a 6224 and I am trying to get two vlans setup where vlan 10 will access the internet through vlan 1. And there is an uplink to a 6248. SRSSW01#show run !Current Configuration: !System Description "Dell 24 Port Gigabit Ethernet, 2.2.0.3, VxWorks5.5.1" !System Software Version 2.2.0.3 ! configure vlan database vlan 10 exit snmp-server location "Server Room" snmp-server contact "Tech Support" hostname "SRSSW01" sntp unicast client enable sntp client poll timer 1024 sntp server 64.147.116.229 clock timezone -8 minutes 0 stack member 1 1 exit ip address 192.168.185.250 255.255.255.0 ip default-gateway 192.168.185.1 ip routing interface vlan 10 routing ip address 192.168.186.100 255.255.255.0 exit username "root" password xxxxxxxxxxxxxxxxxxxx level 15 encrypted ! interface ethernet 1/g2 switchport access vlan 10 exit ! interface ethernet 1/g3 switchport access vlan 10 exit ! interface ethernet 1/g4 switchport access vlan 10 exit ! interface ethernet 1/g5 switchport access vlan 10 exit ! interface ethernet 1/g6 switchport access vlan 10 exit ! interface ethernet 1/g7 switchport access vlan 10 exit ! interface ethernet 1/g8 switchport access vlan 10 exit ! interface ethernet 1/g9 switchport access vlan 10 exit ! interface ethernet 1/g10 switchport access vlan 10 exit ! interface ethernet 1/g11 switchport access vlan 10 exit ! interface ethernet 1/g12 switchport access vlan 10 exit ! interface ethernet 1/g13 switchport mode general no switchport general acceptable-frame-type tagged-only switchport general allowed vlan add 10 tagged switchport general allowed vlan add 1 tagged exit ! interface ethernet 1/g21 channel-group 1 mode auto exit ! interface ethernet 1/g22 channel-group 1 mode auto exit ! interface ethernet 1/g23 channel-group 1 mode auto exit ! interface ethernet 1/g24 channel-group 1 mode auto exit ! interface port-channel 1 description 'Uplink' switchport mode trunk switchport trunk allowed vlan add 1,10 exit exit SRSSW01#
    45 pointsBadges:
    report

Forgot Password

No problem! Submit your e-mail address below. We'll send you an e-mail containing your password.

Your password has been sent to:

To follow this tag...

There was an error processing your information. Please try again later.

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy

Thanks! We'll email you when relevant content is added and updated.

Following